Jump to content
Welcome to our new Citrix community!
  • 0

iPhone USB Re-Direction?

Tim Jenkins


Hi all,

After fiddling around with the XenApp Policies im trying to get an iPhone to re-direct to a virtual desktop. When I plug the iPhone into my machine I get a message which I have attached. When I log into the VM the USB button on the online plugin is greyed out and the iPhone doesn’t appear in my computer. Has anyone tried this out yet?


Edited by: James Mackie on 12-Apr-2010 11:56

USB Re-direction.png

Link to comment

18 answers to this question

Recommended Posts

  • 1

From what I've read, the iPhone/iPad receiver do not support USB (or a number of other features) yet.

from Clash of the Titans - Users, iPads and IT

"Disable device mapping: Although *some of local iPad objects cannot yet be seen within the virtualized desktops/applications (drives, clipbard, etc)*, it is recommended to still disable these features from within the XenDesktop/XenApp farms as a precaution. The Receiver will go through updates and will add new functionality. You, as the administrator, don't want to be surprised when users start copying materials to/from their iPads."

  • Like 1
Link to comment
  • 0

I have only applied a policy to allow shadowing, and one for using universal printers. Nothing to do with USB. When I connect to my XA published desktop, it immediately shows the notification icon about searching for and installing drivers, and when it finishes I get the autorun popup recognizing it as the iphone and asking me if i want to import photos, etc. I also see it listed as Apple iPhone when I go into Computer (what used to be My Computer)...

Link to comment
  • 0

Cheers Wes!

Finally fixed it, had ntohing to do with policies. Basically I had to right click the online plugin > connection center > Session security > Enable everything.


Has anyone managed to get the iphone to be picked up within iTunes? I can see it in my computer as a camera but not in iTunes

Link to comment
  • 0

I believe because the online plugins are used for both Xenapp and Xendesktop, the USB button is suppose to be used for Xendesktop only. If you follow the steps through the connection centre, you should find that USB devices are are supported in XA6 should be re-directed. I have tried a all in one canon pritner/scanner but the scanner side didnt re-direct.

Link to comment
  • 0

Odd, I could have sworn that I saw somewhere that the XenDesktop USB functionality, including the USB Online Plug-In button, was going to work in XenApp 6. I seem to be having no new USB capabilities than I did in XenApp 5.

Anyway, on a side note, I'm glad you got the iPhone working but has anyone gotten a Blackberry to pass through? I've been unsuccessful.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...