Jump to content
  • 0

"Alt gr" Key won't work under XenServer 5.5 in Linux Guest


Rainer Frühwacht

Question

Hey,

i installed under my XenServer 5.5 a Linux Debian Lenny Guest in German language. I need special characters like € and @ for example, etc. These are entered in combination with the ALT GR key on a german keyboard layout. But nothing happend, when i use this "alt gr" key in combination with an special character. In the XenCenter
Options (under Console), i changed the Shortcuts from "Alt gr" to F12 and F11 Keys, but no change, when i
try it again.

I have no problems with Windows Clients, only under Linux.
When i connect via putty.exe to my Linux Guest, the "alt gr" key is working fine.

Sorry for my very bad english!

Any Idea?

Thx a lot

Rainer

Link to comment

8 answers to this question

Recommended Posts

  • 0

Hi Rainer,

you could try this workaround: first set Full-Screen mode to F12. If you now use <ALT GR> Q to enter the @ nothing happens at the first keypress, but at the second the @ appears... If you want to type the Pipe, you first have to press <ALT GR> Q and then <ALT GR> | without letting off <ALT GR> between the keys.

Not nice but it works for a short maintenance session.

regards,
Ingo

Link to comment
  • 0

Hi Ingo,

hoffe es ist Ok, wenn man sich hier auch kurz auf deutsch unterhalten kann?

Danke für Deinen Vorschlag, hat aber leider nicht funktioniert. Als ich jedoch mehrere
Varianten durchprobiert habe, bin ich auf eine seltsame Kombination gestossen, mit der ich mir
die Sonderzeichen holen kann.

Nämlich, schnell _hintereinander_ die Taste STRG ALT GR Sonderzeichen. Die Tasten müssen
aber wirklich schnell getippt werden, sonst klappt es nicht. Seltsame Variante, aber es geht.

Löst natürlich das Problem nicht und ich wundere mich, weshalb man darüber nichts im Netz findet,
dass müssen doch alle Benutzer haben, dass Problem?!

Gruß
Rainer

Link to comment
  • 0

Hi,

dass wäre interessant, aber ich habe noch niemanden in den gängigen Foren gefunden, der mir
diese Frage beantworten könnte. Du warst bis jetzt der einzige, der auch dieses Problem hat.

Wenn mir Citrix mitteilen würde, dass das noch ein Bug in der 5.5 ist, wäre das ja ok, dann weiß man Bescheid,
so suche ich den Fehler halt in meiner Umgebung. Ich behelf mir zwar mit meinem Workaround, aber
das ist eben keine saubere Lösung.

Danke Dir für Deine Antwort.

Vielleicht kann man sich in Zukunft ja noch über das Thema austauschen.

Gruß
Rainer

Link to comment
  • 0

A bit late, i know.
But for all Google users it may be useful:

In Xen Center 6.2 my solution was to change the keyboard settings of the Suse Screen to "Great Britain". Thereafter you can get @ an | with Shift ä and Shift >

In deutsch:
Wenn man den SLES oder SUSE Screen (Anmeldefenster) auf Englisch wechselt, kann man die englische Tastenbelegung nutzen, die anscheinend nicht mit den Xen Center Einstellungen kollidiert. Natürlich liegt dann auch das z auf dem y und vice versa. @ erreicht man dann über Shift-ä, Pipe bzw. | über Shift->

mfg
Manfred

Link to comment
  • 0

In XenCenter 8.1 (build 8.1.2.7319) still not fixed.

My workaround:

I change the layout to "English", write the email address in the "Keyboard Test", mark and copy it and change the layout back to "German".

Then I have the email address available in the XenCenter Console clipboard when I need it later for the registration.

 

It is such a shame that Citrix isn't capable to fix it since more than 10 years, but their sale department is bothering me regarding a license...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...