Jump to content
Welcome to our new Citrix community!
  • 0

How add windows file sharing (CIFS) ISO library using xe command


Andy Zhu

Question

11 answers to this question

Recommended Posts

  • 0

Hi Andy,

Kindly follow the below mentioned steps to add Windows CIFS ISO library using CLI when the CIFS share is protected by username and password,

1. xe sr-introduce content-type=iso name-label=namelable shared=true type=iso uuid=<UUID>(uuid can be obtained by running the command uuidgen in XenServer)

2. xe pbd-create sr-uuid=<SR UUID> host-uuid=<HOST UUID> device-config:location=< //IP/sharename > ( //10.130.215.204/share ) device-config:options="-t cifs" device-config:username=<username> device-config:cifspassword=<password>

if there is no username/password protection to the share,then the below command is sufficient

#xe-mount-iso-sr //IP/share -t cifs

Example: #xe-mount-iso-sr //10.130.215.204/share -t cifs

Regards,
Antony.

Link to comment
  • 0

you can use xe sr-create command.

xe sr-create content-type=iso type=iso host-uuid=<host-uuid> shared=true device-config:location=//192.168.1.100/iso device-config:username=<cifs username> device-config:cifspassword=<cifspassword> name-label="ISO SR label"

cheers

Link to comment
  • 0

I'm suddenly having issues mounting any CIFS repo. My old storage box used to host such a repo, but I deleted it a while ago when we upgraded to newer file storage. Trying to create a CIFS repo on the old box now fails, but this is probably due to some DNS weirdness with that box. Trying to mount a CIFS repo from my Win7 machine, gives the message "Unable to mount the directory specified in device configuration request. Check your settings and try again." Trying to mount a share from our new storage (Synology) gives the same message. Also tried NFS method. Trying to create the CIFS repo from a share on any server via the commandlines as shown above creates a "CIFS ISO Library" node in XenCenter's Infrastructure tree, but it has a red X on it, and if I try to "repair" it, that fails.

How can I figure out what is going wrong and what changed? I can't create any new VMs from install media ISOs until I can figure this out.

Link to comment
  • 0

Thanks for reading me!

Well, I certainly disabled SMB1 on my machine, but unless XenServer is enforcing SMB2+, it should still work the way it always did on the old box - DSS hasn't been updated in years. Pretty sure Synology is also set to SMB2+, as it should be. Does XS6.5 only understand SMB1? That's a little scary.

The DNS issue with the old box probably has something to do with it as well. Using the same realm, IP, and login that has worked for years, the old box cannot communicate with our ADS. Open-e support (which we don't have a contract for, and even if we did, DSSv6 is EOL) said they had no idea what was wrong.

Are there some logs in XenServer that might cast light on exactly what the issue is? I don't see anything relevant on our ADS.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...