Jump to content
Welcome to our new Citrix community!

Gateway portal nFactor and theme translation


Joost Sannen
Go to solution Solved by Joost Sannen,

Recommended Posts

Hi, after a support case and asking around in the field I have 2 problems left in translating my Gateway portal theme based on RfWebUI. I can translate all applicable fields except

  • User name
  • Please supply either username as saamaccountname

I'm using nFactor based on OnlyUsername.xml. I can force 1 language so momentarily 'Please supply either username as saamaccountname' is empty.

How to translate it properly?

image.png.e18b5409042822d28a78b116eaa5350b.png 

image.png.b46eaf833c2a6f2d33e501a63537ba85.png

Link to comment
Share on other sites

Hello Joost,

Which Language you would like to have this converted. Currently we support below languages as mentioned in tab and you can select any one of them:

image.thumb.png.5684f74416629fad500bc4390ff92070.png 

More over if you would like to change field names you can click on top right "edit" button and change it appropriately:

image.thumb.png.26ed240f2ab2786c69edb220859924b7.pngThanks and regards,

Hemang

Link to comment
Share on other sites

@Hemang Raval​ , I know the options but it still doesn't work for me on 13.1-50.23 . I'll do another attempt in my sandbox environment with the latest 14.1 version.

@Fernando Avelino​ , great article! I'm aware of some of the possibilities. When the sandbox environment does not function too I'll try to use the mentioned techniques in this article.

Link to comment
Share on other sites

  • 2 weeks later...

@Hemang Raval​ . Well, in the end I couldn't get it fully functional on a new Netscaler 14.1 .

The GUI is buggy. When you try to update language labels of an existing login schema it states that the language file couldn't be modified.

image.png.13c4781490b7d1cbcd2dcb089316f0af.png 

image.png.c51ca678479f6a5b1c54b55b5fcf0a1b.pngimage.png.d7813d6102d4ef1b98e8f5bd66a59c1d.pngBut behind that there's another notification.

image.png.3af668c4a570b5b35240b834123be4d4.pngIt appears all label modifications you'll do in the gui changes the specific language json files in /var/netscaler/logon/LogonPoint/custom/ .

But I did find a solution. I follow up shortly.

Link to comment
Share on other sites

  • Solution

The login schema of OnlyUsername.xml differs between 13.1 and 14.1 . I couldn't get the label translation working with the default one in 13.1 .

GOAL

  • Change 'User name' to 'Username :' and in Dutch 'Gebruikersnaam :'
  • Remove the assistive text in the username box.
  • Change ' Please enter UserName ...' to 'Enter your credentials for [NAME OF SERVICE] and in Dutch 'Voer uw account in voor toegang tot [NAME OF SERVICE]'

What I did is

  • Use the OnlyUsername.xml from 14.1 on my 13.1 production Netscaler.
  • Removed all values in strings.en.json and strings.nl.json in /var/netscaler/logon/LogonPoint/custom/
  • Edited strings.en.json and strings.nl.json in my custom theme located /var/netscaler/logon/themes/[THEME NAME]/

Warning: If you don't get immediate proper results this might be the internal Netscaler caching. Even when the integrated caching feature is not enabled. Invalidate objects of the loginstaticobjects content group by flushing objects. Reopen an InPrivate browser and try again.

My json files

strings.en.json

{

"onlyusername_user_name":"Username :",

"onlyusername_please_enter_username_...":"Enter your credentials for [NAME OF SERVICE]",

"onlyusername_please_supply_either_username_as_saamaccountname":""

}

strings.nl.json

{

"onlyusername_user_name":"Gebruikersnaam :",

"onlyusername_please_supply_either_username_as_saamaccountname":"",

"onlyusername_please_enter_username_...":"Voer uw account in voor toegang tot [NAME OF SERVICE]"

}

@Hemang Raval​ this may need some improvement in Netscaler.

Regards, Joost

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...