Jump to content
  • 0

Problem connecting the second Delivery Controller to the base ms sql


Cezary

Question

Hello,

For several days, my team and I have been struggling with the problem of adding a second controller.

We create a new farm version 2402LTSR in our new domain. All hosted in vmware vSphere actually ver. and Windows Server 2019 with all updates.

The Citrix installer installed ms sql express on the DC1 server and configured it. I have created a Site and want to add a second controller. The script logged in and created a user with the computer name DC2 and also entered information about the second controller into the database, but when trying to log in to the databases, an error occurs.

r/Citrix - Problem connecting the second Delivery Controller to the base ms sql

The logs on DC1, where the base is located, reflect this problem

Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication. [CLIENT: DC2IPV4]

and

SSPI handshake failed with error code 0xc0000199, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The operating system error code indicates the cause of failure. [CLIENT: DC2IPV4]

Both servers are in the same domain and in the same VLAN. All traffic needed for MS SQL is allowed and goes through telnet.

Servers resolve correctly via nslookup etc.

What we've checked so far:

I installed mssql management studio on DC2 and through managemnt studio I can easily access the databases on DC1

I gave the user DOMAIN\DC2$, which was created on the database via a Citrix script, full sysadmin rights

I tried to run the MS SQL service as the user "MSSQL$INSTANCENAME" instead of the standard network service

We checked all network and firewall issues

I added an entry to the registry regarding loopback (google suggested it)

When I installed the database on a separate server where I manually installed the MS SQL EXPRESS 2022 product, it was impossible to create a site at all because it was not possible to log in to the database from any controller.

I tried running the site manager as different users, even Domain Admin or SQL Servers Admin

We tried adding servers to a new OU that does not contain any policies to rule out a GPO problem.

The second controller was able to connect to the Database on the DC1 controller via the Site Manager program because the DOMAIN\DC2$ user and entries regarding the second controller were created on the database. So some high permissions to edit Citrix databases worked.

However, when logging into these databases, Site Manager has a problem.

I don't have any more ideas.

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...