Jump to content
Welcome to our new Citrix community!
  • 0

Adobe Reader Windows Cryptographic Services Issues


CosmicAnomaly

Question

My organization deploys 32 bit Adobe Reader to our users via an Image that resides on Windows Server 2016. 

Recently we have begun to have 2-5 users per day experience an issue where the 'Sign' button when digitally signing inside the application will not respond. It will change color to indicate that something is happening, but nothing follows. 

If we disable the 'Modern UI for Digitally Signing', we can force the application to throw one of two errors. 

image.png.fae532b0177e0062d8bd8a7ff352f7fc.pngimage.png.88d397f8fd4dcfb66575ace874948e32.png

We tracked user profile types, but the issue occurs for users labeled as local, roaming or mandatory. The users signatures are valid, certificates not expired. 

There seems to be a communication failure happening or when the user first connects something doesn't fully connect correctly. The issue is resolved 100% of the time by moving them to a new session/server. 

It is also entirely random, with no way to replicate or force the behavior. 

Adobe will not provide support for Reader as it is a free application, but I was hoping someone here may have seen this before or have some suggestions on what additional troubleshooting we can perform to work towards a resolution. 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...