Jump to content
Welcome to our new Citrix community!

HA Pair set up failing with "Unable to fetch configuration from primary, please check ns.log for reason"


Recommended Posts

Hello

 

I'm setting up a new 14.1 HA Pair with VPX appliances. I've licensed both appliances, created two certificates for NSIP (same name, different common name in the SSL_NOSYNC folder) and this is all working well as far as I can see.

 

I'm setting up the pair and going through the process, including changing the RPC node passwords. The initial setup works fine. When I go to set a force sync, it fails with error above.

 

The errors that appear on the secondary appliance ns.log are as follows:

 

Send HA File sync to netsvc

nsnetssl_init: CA file is not configured

nsnetssl_init() failed!
ns_delete_kek_keyfragmentsfiles(): Deleting KEK fragments with suffix 335952024_02_06_13_16_59. Path id: 1.

 

I've checked links for certs and they are all configured. I've updated the three internal services with the appliance cert and added both the intermediate and root cert, all to no avail.

 

Anyone know where its stating that the CA file is not configured? I've reset these appliances several times now and tried to complete this in different ways but getting the same error.

 

Any advice appreciated.

 

Thanks

 

Russell

 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...