Jump to content
Welcome to our new Citrix community!
  • 0

After ELM update to 23.12.0.1001, getting certificate error on update to OS Layer


Question

ELM - 23.12
vSphere 7
Windows 10

 

Issue only seems to happen if offload composting is enabled on the connector.

 

"An unexpected system error occurred. If your ELM is not running the latest release, please try to upgrade it and retry the operation. If it continues to fail while running the latest release please contact technical support. Exception Message: Certificate doesn't contain private key Exception Details:"

 

Rebooted ELM, tried again, same issue.

Completed steps from (https://support.citrix.com/article/CTX339978/app-layering-the-issuing-certificate-does-not-have-a-usable-private-key), rebooted ELM, tried again, same issue.  

Link to comment

1 answer to this question

Recommended Posts

  • 0

Was able to resolve the issue this morning by performing the following steps:

 

1.       Deleted the existing VMware vSphere connectors with Offload Composting.

2.       Re-created the VMware vSphere connectors with Offload Composting.

3.       Followed the steps from CTX296764 and delete the certificates and restart the services.

4.       Rebooted the ELM

 

Tested and the certificate issue is gone now.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...