Jump to content
Welcome to our new Citrix community!

Citrix ADC 13.0.92nc /var/nslog newnslog.* are not zipped


Recommended Posts

Hey all,

 

i know there are multiple articles arelady in the www but i cannot seem to ged a hold on my issue.

we do have a VPX HA Pair 13.0.92nc and i wanted to make a upgrade to the latest 13.1 version.

So i did check the file usgae with df -h and on my primary node the /var/nslog folder is taking a big chunk with a lot of files not beeing zipped but half of the exisitng files are propperly zipped. the Number ranges from 1-99 in my rotation.

i did check the nslog.nextzip & nslog.nextfile both do have different numbers and are not empty.

https://support.citrix.com/article/CTX205014/netscaler-newnslog-files-not-compressed-which-results-in-var-directory-getting-full is not helping since it mentioneds that only new files will be zipped.

image.thumb.png.1c105bbaf8b685d4fd140ab735a80b34.png

 

if i check the same directory in the Second HA Node every file is propperly zipped.

I tried to follow https://docs.netscaler.com/en-us/citrix-adc/current-release/system/troubleshooting-citrix-adc/how-to-free-space-on-var-directory.html

but the command to zip the unziped files failed, so i added the "f" operator and it did create the file but the folde still remains
 

image.thumb.png.ebb42ef85b319891ed12392f9ad771ac.png

 

So here is my quesions:

- what the heck iam doing wrong, that the primary node is not ziping all its files

- do i really need to zip each file by hand and delete the folders?

 

OR is it safe to just delete all the non zipped newnslog  files to free up the disk space?

 

thanks!

Link to comment
Share on other sites

The newnslog files store logs, events, and statistics from the many internal counters. If you don't need this historic information, it is safe to delete them.

Looking at your list of files, looks like the most recent is from Nov 24 12:54 and it is compressed, which makes me think that somehow you solved the automatic compressing issue. (maybe you fixed a problem in the nslog.nextzip file?)

On the tar command to compress the folder you need to put a ./ (dot and slash) before the folder name (or the full path), like this:
tar -cz newnslog.13.tar.gz ./newnslog.13

It will not remove the folder automatically, just create a compressed file of the folder contents. After that you have to manually delete each folder.

 

Hope it helps,

Marcelo Oguma

  • Like 1
Link to comment
Share on other sites

Hey Marcelo,

 

thanks for your answer, i was curious why all the remaining files were not zipped and i was not sure if i could delte the files.

Well it seems that my issue is solved now all files are zipped now, maybe the process was not hanging and due to my interactions on the shell its working now.

 

thanks again for the assist

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...