Jump to content
Welcome to our new Citrix community!
  • 0

Elastic layer not attached - (0x80004005): The semaphore timeout period has expired


Alexey Kutuzov1709163409

Question

Hi All,
Came accross with an issue when occasionaly one or a few elastic layers are not connected to a pooled desktop on a user logon.
If the user makes a new logon immediately then all elastic layers attached successfully. 
I found the following error in the log:

2023-10-31 08:10:48,717 ERROR 14 NativeMethodLogger: Failed to attach virtual disk '\\fs.domain.com\VOL1_ElasticLayer\Unidesk\Layers\App\P1212498.R1.vhd' with options 'ReadOnly, NoDriveLetter, Permanent': Error code 121
2023-10-31 08:10:49,014 ERROR 27 CompositingManager: Could not load disk 'Unidesk/Layers/App/P1212498.R1.vhd', but continuing anyway
2023-10-31 08:10:49,014 ERROR 26 CompositingManager: Could not load disk 'Unidesk/Layers/App/P1212498.R1.vhd', but continuing anyway
2023-10-31 08:10:49,014 ERROR 6 CompositingManager: Could not load disk 'Unidesk/Layers/App/P1212498.R1.vhd', but continuing anyway
2023-10-31 08:10:49,014 ERROR 21 CompositingManager: Could not load disk 'Unidesk/Layers/App/P1212498.R1.vhd', but continuing anyway
2023-10-31 08:10:49,029 ERROR 21 CompositingManager: Caught exception: 'System.ComponentModel.Win32Exception (0x80004005): The semaphore timeout period has expired

 

Please, advise what to check.

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...