Jump to content
Welcome to our new Citrix community!
  • 0

Vmware appliance with hyperV packaging


Chris Bondy1709160344

Question

Is it possible to connect a HyperV agent to an ELM running on Vmware?  So far I keep getting errors when I try to register the agent.  I have ruled out the firewall.  (see below, obviously I have the correct IP in the actual commands)

 

2023-10-27 14:43:44,894 INFO 1 Program: *** Citrix.AppLayering.Agent.Service called as an Executable! build 23.9.0.6 ***
2023-10-27 14:43:44,909 INFO 1 Program: CommandLine Arg: register
2023-10-27 14:43:44,909 INFO 1 Program: CommandLine Arg: /i
2023-10-27 14:43:44,909 INFO 1 Program: CommandLine Arg: /e:*IP OF ELM*
2023-10-27 14:43:44,925 INFO 1 Program: CommandLine Arg: /u:Administrator
2023-10-27 14:43:44,925 INFO 1 Program: CommandLine Arg: /s:443
2023-10-27 14:43:45,050 INFO 1 ServicesInstaller: Installing Services
2023-10-27 14:43:45,081 INFO 1 HookStartupService: No Hook Assemblies defined.  No Hooks will be loaded.
2023-10-27 14:43:45,097 INFO 1 HookStartupService: Loading 0 Assemblies
2023-10-27 14:43:45,128 INFO 1 EncryptionProviderInstaller: Installing EncryptionProvider
2023-10-27 14:43:45,144 INFO 1 HandlersInstaller: Installing Command/Query Handlers
2023-10-27 14:43:45,222 INFO 1 Program: Register called with elmAddress: *IP OF ELM*, user: Administrator
2023-10-27 14:44:00,903 INFO 1 ElmRegistrationService: Attempting to register with ELM *IP OF ELM*
2023-10-27 14:44:01,121 INFO 1 ElmWebClientService: Logging into ELM as Administrator
2023-10-27 14:44:01,325 INFO 1 ElmRegistrationService: AgentRevision: 23.9.0.6

Link to comment

16 answers to this question

Recommended Posts

  • 0

What are you trying to do.  If its be able to publish images to HyperV from your vmware appliance you need to create a platform layer on HyperV then install the hyperv vm tools in that.  Then when you publish you will have  them.  Makke sure to use a offload compositing connector to make that then i think it will eb able to boot.

Link to comment
  • 0

We are migrating most of our Citrix workloads to Hyper V.  For now we are keeping infrastructure in VMware.  I'd like to keep my ELM in VMware but run our desktop/server host VMs in HyperV.  I was able to get a host machine in HyperV to boot the current image created by the ELM from PVS but it gets a BSOD.  From my research it appears that the issue stems from the image being created with a VM on different hardware (VMware).  I was attempting to connect HyperV so I could create our images from HyperV templates.  

Link to comment
  • 0

Yes I can ping it from the hyper V server.  I checked and port 443 is open between them.  I also checked 8016 just in case.  I also checked to make sure bits is enabled.  The installation works fine if I skip the registration.  Its the registration that fails.  

 

Failed to register with the ELM:
System.Net.WebException: The operation has timed out
   at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Citrix.AppLayering.Agent.Service.MaApiReference.Api.CreateInfrastructure(CreateInfrastructureCommand command)
   at Citrix.AppLayering.Agent.Service.Services.ElmRegistrationService.RegisterWithElm(String hostName, Int32 port, Boolean useSSL, String userName, String password, Boolean ignoreCertErrors, String comment)
   at Citrix.AppLayering.Agent.Service.Program.CommandLineArgsHandler.Register(String elmAddress, String user, Int32 securePort, Boolean ignoreCertErrors, String comment)

Link to comment
  • 0

I made sure that I am using the same version of agent that matches the ELM version.  I also checked that I'm using the correct IP and restarted the ELM.  I also set up an ELM appliance in HyperV just to rule out the mismatched hypervisors and I still get the same error when registering the agent.  I am a local admin on the server where I am installing the agent.

Link to comment
  • 0

The error indicates you can get to the appliance so its timing out.  Is there a proxy configured on the hyperv host?  You will probably have to 

On 10/27/2023 at 2:55 PM, Chris Bondy1709160344 said:

I am chatting wiht engineering.  They asked:

Does the CreateInfrastructureCommand show up in the web.log on the ELM?

If you download the log bundle from the elm you will find the web.log

 

Link to comment
  • 0

I downloaded the web.log file.  I do see the CreateInfrastructureCommand.

 

2023-10-31 12:01:03,734 ERROR [21447] CICH3  ConnectivityTester: ConnectivityTester TestConnection() caught Tcp exception System.Net.Sockets.SocketException (0x80004005): Connection timed out
  at System.Net.Sockets.TcpClient..ctor (System.String hostname, System.Int32 port) [0x0006d] in /builddir/build/BUILD/mono-6.12.0.107/mcs/class/referencesource/System/net/System/Net/Sockets/TCPClient.cs:122 
  at Unidesk.Ma.Web.Services.ConnectivityTester.TestConnection (System.String ipAddress, System.Int32 port) [0x00000] in C:\jenkins\ws-Applayering.Services-23.9.fenway\Unidesk.Ma\Web\Services\ConnectivityTester.cs:19  when trying to connect to hyperVisor
2023-10-31 12:01:03,734 INFO  [21447]        HandlerHelper: Finished Command CreateInfrastructureCommand->UpdateInfrastructureResult
2023-10-31 12:01:03,734 ERROR [21447]        HandlerHelper: 'Application Error while processing 'Command' 'CreateInfrastructureCommand'': 'DefaultTitle="", MessageID="AgentCommunicationError", {CategoryData={[AgentCommunicationErrorCategory { ExceptionMessage = "Connection timed out", Address = "DNS_NAME_HYPERV_HOST:8016" }]}'
2023-10-31 12:01:03,735 ERROR [21447]        HandlerHelper: Title: Error  Message: An error occurred while attempting to communicate with the application layering agent at 'DNS_NAME_HYPERV_HOST'  Details: Server address: DNS_NAME_HYPERV_HOST:8016
System message: Connection timed out

Link to comment
  • 0

When you said 8016 was open that was from appliance to agent ?

 

You also need these

 

App Layering Source       App Layering Destination    Activity            Protocol    Ports

Agent on Hyper-V               serverAppliance            Disk download     TCP3012 (HTTP), 3512 (HTTPS)

Agent on Hyper-V              serverAppliance             Disk upload           TCP3015 (HTTP), 3515 (HTTPS)

Agent                                   Appliance                         Log deliveries from agent    TCP8787

User Interface                  Appliance                                                                    3512

see

https://docs.citrix.com/en-us/citrix-app-layering/4/manage/firewall-ports.html

 

But it seems like the appliance cant talk back to the aent on 8016 according to the error you posted.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...