Jump to content
Welcome to our new Citrix community!
  • 0

WEM agent takes 2 minutes to initialize


Martijn

Question

WEM 2308 / Citrix 2203 LTSR on W2019.

 

According to the WEM init logfile and agent log the init only takes 7 seconds. Yet it takes around 2 minutes for the agent icon to appear in the user's tray.

 

The  Citrix Workspace Environment Management Agent User Session Utility Log shows this, note the time 9:14:19 which is about the logon time:

 

Start Time: 27/10/2023 9:14:19

Version: 2308.1.0.1

9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMApps -> True
9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMPrinters -> False
9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMNetDrives -> True
9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMVirtualDrives -> True
9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMRegValues -> True
9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMEnvVariables -> True
9:14:19 Info -> VuemAgentConfigurationHelper.LogOptionState() : processVUEMPorts -> False

 

But then in the  WEM Agent log, you can see 9:16:35. So more than 2 minutes:

 

------------------------------------------------------------------------------------------------

 Citrix Workspace Environment Management Agent Log

------------------------------------------------------------------------------------------------

Log Start : 9:16:35 vrijdag 27 oktober 2023


Agent Version: 2308.1.0.1

9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentPreventExitForAdmins -> False
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : DisableAdministrativeRefreshFeedback -> False
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : UIAgentHelpLink -> 
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : UIAgentCustomLink -> 
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentAllowScreenCapture -> False
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentScreenCaptureEnableSendSupportEmail -> False
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentScreenCaptureSupportEmailAddress -> 
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentScreenCaptureSupportEmailTemplate -> 
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentShutdownAfterIdleEnabled -> False
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentShutdownAfterIdleTime -> 1800
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentShutdownAfterEnabled -> False
9:16:35 Event -> VuemAgentConfigurationHelper.LogOptionState() : AgentShutdownAfter -> 02:00:00

 

Any idea how to fix this? There is no agent delay set in the config. It's not a HUGE deal because the user can work, but some apps rely on settings pushed through WEM which are not ready yet, so some applications only work once the 2 minutes are over.

Link to comment

3 answers to this question

Recommended Posts

  • 0
On 10/27/2023 at 3:22 PM, Jeff Riechers1709152667 said:

On your image before you seal it for deployment, run "C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe" -refreshcache  This will ensure your local policies are cached.  See if that gets it to kick off quicker.

Thanks for the suggestion, but BIS-F is doing this for me. Also, the WEM Cache is not on the persistent drive so it's clean every reboot and gets refreshed then. So I don't think that's what causing it. All agents are green in the console as well.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...