Jump to content
Welcome to our new Citrix community!
  • 0

CitrixOptimizer settings not applied in published image


Sergio Masone1709161115

Question

I dont know if this is app layering specific, but i noticed when i run Citrixoptimizationtool  , my optimizations arent carried forward in the VDAs. as a workaround i use WEM to apply a custom template template at bootup, but curious to see if others have this behavior.. the optimizations that don't seem to carry are scheduled tasks that get disabled. Ive tried in the OS layer, platform layer, an app layer, same thing post publish, scheduled task optimizations aren't there. The VDAs dont have the disabled scheduled tasks applied to them. I tried different versions of the optimizer, and have some vdas that we dont use app layering with and dont seem to be affected by this. Im now on app layering 2309 and still have this problem. Anyone else experiencing this behavior? VDAs are windows 10 22h2

Link to comment

3 answers to this question

Recommended Posts

  • 1

Hi Sergio,

In our code we dont allow a scheduled task from the OS Layer to be disabled in an Application or Platform layer.  You can add a new scheduled task in  layer but not change the existing ones.  There are two options to handle this.  You can run the optimizer on a new version of your OS layer where those tasks can be disabled or we have a way to disable the way we treat the scheduled tasks when making a layer.

 

To disable what we call scrubbing you need to create a lyer that will disable schedule tasks you can set this registry setting on your packaging machine when creating the laer:

 

Create a  DWORD named  HKLM\Software\Unidesk\Ulayer\DisableScheduledTasksScrubOnFinalize    and set it to 1

 

Hope this helps

 

Rob

  • Like 2
Link to comment
  • 0
On 10/25/2023 at 9:04 AM, Rob Zylowski1709158051 said:

Hi Sergio,

In our code we dont allow a scheduled task from the OS Layer to be disabled in an Application or Platform layer.  You can add a new scheduled task in  layer but not change the existing ones.  There are two options to handle this.  You can run the optimizer on a new version of your OS layer where those tasks can be disabled or we have a way to disable the way we treat the scheduled tasks when making a layer.

 

To disable what we call scrubbing you need to create a lyer that will disable schedule tasks you can set this registry setting on your packaging machine when creating the laer:

 

Create a  DWORD named  HKLM\Software\Unidesk\Ulayer\DisableScheduledTasksScrubOnFinalize    and set it to 1

 

Hope this helps

 

Rob

Thanks Rob,
I didn't know about this registry setting, seems to work now, it persists in the template.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...