Jump to content
  • 0

Does the Workspace App 2203 CU4 with Desktop Lock Work?


Greg Beck

Question

Does anyone have 2203 working reliably with desktop lock?   I am trying to get our current devices migrated to 2203 but I haven't been able to get it to work reliably. 

 

Most users are logging in with a new profile. Sometimes it won't connect for the user, where the only workaround we have found is removing the local profile and trying again. Once a profile works once it seems to keep working.  I have found when it is broken under the user registry HKCU\SOFTWARE\Citrix\Dazzle\Sites\site-####\ isn't fully populated.  Specifically, it will always have "storeConfigurationStatus"="configPending".  

 

To test a wrote a script that would login to a VM configured with Desktop Lock, then check to see if the session showed up in Citrix, reset the VM snapshot, and repeat. For my control I had 1 VM configured with 1912 Desktop Lock running at the same time. 

1912 Desktop Lock: worked 100% of the time. 

2203 Desktop Lock: worked 113 out of 176 times (~64% of the time).

 

I did find https://discussions.citrix.com/topic/417347-workspace-app-sso-broken-for-first-sign-in/ which seems like a similar issue. I tried the settings mentioned in that post, but it doesn't seem to have made any difference. 

 

 

I am wondering if anyone has it 2203 Desktop Lock working or if I am just chasing my tail with this version.

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...