Jump to content
Welcome to our new Citrix community!
  • 0

a snapshot could not be created from the specified virtual machine: XDHyp:\Hostingunits\mysharedresources\windowsserver2019 base image.vm


Ram Thota

Question

I have installed Citrix Virtual Apps and Desktop 7 2305 OP setup and I am able to create a Machine Catalog and 2 VDIs with Single session OS(Base Image: Windows 10). But Machine Catalog and vms failed to create with Multi-session OS (Windows Server 2019). I have performed below troubleshooting steps given in Citrix DOCS, but not helpful:

 

  • tried installing separately packed Multi-sessions OS VDA 2305.1 component on Base Image.
  • Re installing the VDA 2305.1 multiple times on the same Base Image and also tried on different new Image.
  • Enabled Machine Identity service in Registry key on Base Image. 
  • Selected "create a master MCS image" while installing VDA on Base image.

 

Since We don't have Partner support Entitlement(expired), I am unable to open a support case.

 

I am getting below error code and log message.

 

" A snapshot could not be created from the specified virtual machine"

 

Error Id: XDDS:64429B6D

Exception:

   DesktopStudio_ErrorId : FailedToCreateSnapshot

   Error Source : CitrixHostService

   Sdk Error Message : The create snapshot operation failed.

   Sdk Error ID : Citrix.XDPowerShell.HostStatus.FailedToCreateSnapshot,Citrix.Host.Sdk.Commands.NewHypVMSnapshotCommand

   ErrorCategory : NotSpecified

   DesktopStudio_PowerShellHistory : Create Machine Catalog 'MS-2019'

   25-08-2023 09:40:58

  

   Get-LogSite  -AdminAddress "cvad.fnmp.com:80" -BearerToken ********

   Start-LogHighLevelOperation  -AdminAddress "cvad.fnmp.com:80" -BearerToken ******** -Source "Studio" -StartTime "25-08-2023 04:10:44" -Text "Create Machine Catalog `'MS-2019`'"

   New-BrokerCatalog  -AdminAddress "cvad.fnmp.com:80" -AllocationType "Random" -BearerToken ******** -IsRemotePC $False -LoggingId "daa9d78b-b3ef-4ad6-acb0-5857baa471d6" -MinimumFunctionalLevel "L7_9" -Name "MS-2019" -PersistUserChanges "Discard" -ProvisioningType "MCS" -Scope @() -SessionSupport "MultiSession" -ZoneUid "3f92290a-090f-4a69-986b-56bbbabdcfcf"

   New-AcctIdentityPool  -AdminAddress "cvad.fnmp.com:80" -AllowUnicode -BearerToken ******** -Domain "fnmp.com" -IdentityPoolName "MS-2019" -LoggingId "daa9d78b-b3ef-4ad6-acb0-5857baa471d6" -NamingScheme "MS2019VDI#1" -NamingSchemeType "Numeric" -Scope @() -ZoneUid "3f92290a-090f-4a69-986b-56bbbabdcfcf"

   Set-BrokerCatalogMetadata  -AdminAddress "cvad.fnmp.com:80" -BearerToken ******** -CatalogId 16 -LoggingId "daa9d78b-b3ef-4ad6-acb0-5857baa471d6" -Map "System.Collections.Generic.Dictionary``2`[System.String,System.String`]"

   New-HypVMSnapshot  -AdminAddress "cvad.fnmp.com:80" -BearerToken ******** -LiteralPath "XDHyp:\HostingUnits\Xen Server 241\Windows Server 2019 Base Image.vm" -LoggingId "daa9d78b-b3ef-4ad6-acb0-5857baa471d6" -SnapshotName "Citrix_XD_MS-2019"

   New-HypVMSnapshot : The create snapshot operation failed.

     + CategoryInfo : InvalidOperation: (:) [New-HypVMSnapshot], InvalidOperationException

     + FullyQualifiedErrorId : Citrix.XDPowerShell.HostStatus.FailedToCreateSnapshot,Citrix.Host.Sdk.Commands.NewHypVMSnapshotCommand

   Stop-LogHighLevelOperation  -AdminAddress "cvad.fnmp.com:80" -BearerToken ******** -EndTime "25-08-2023 04:10:58" -HighLevelOperationId "daa9d78b-b3ef-4ad6-acb0-5857baa471d6" -IsSuccessful $False

  

  

   StackTrace: Citrix.Orchestration.Base.LogicModels.Exceptions.ScriptException A snapshot could not be created from the specified virtual machine: XDHyp:\HostingUnits\Xen Server 241\Windows Server 2019 Base Image.vm

      at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.Scripts.SnapshotVMsScript.CreateVMSnapShot(String vmPath)

      at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.Scripts.SnapshotVMsScript.RunScript()

      at Citrix.Orchestration.Base.PowerShellInteraction.PowerShellScript`1.Run()

      at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.SnapshotCreationTask.RunTask()

      at Citrix.Orchestration.Base.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()

 

 

Could you please take a look and help me resolving this issue and let me know if you need any more details from my end.

Thank you 

Regards

Ram

Link to comment

4 answers to this question

Recommended Posts

  • 0

When creating the Catalog, did you choose the machine instead of choosing a snapshot? If you choose the machine, then MCS tries to create a snapshot for you. Does your service account in the Hosting Resource have permission to create the snapshot? You might have to look at logs on your hypervisor to determine why it couldn't create the snapshot. What is your hypervisor?

Link to comment
  • 0

Thank you Carl for the Reply, I have chosen Base Image/Gold Image and not any snapshot while creating the Machine Catalog. I have given the root credentials of the hosting resource, so it should have all the permissions. I am using the Xen Hypervisor Server. Could you please direct me to the correct log file to check?

 

 

image.png

image.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...