Jump to content
Welcome to our new Citrix community!

Load Balanced Softphone Web App


Andrew Pilgrim

Recommended Posts

I am sorry this is a bit generic but for now it's a simple question. Has anyone has successfully got a softphone application to actually work via the Netscalers?

We have been asked to load balance our internal servicedesk phone system and i am running into issues because it has an integrated softphone feature.

I have got the basic load balancing of the web client sorted using HTTPS but i am running into problems trying to get the softphone integration working. I know this use's UDP protocol but i cannot get it to work.

I have tried setting up the virtual server as UDP protocol with ANY port allowed and tried that with both a Service group made up of the 2 physical servers as well as individual services for each server, again set up to allow ANY port and just does not work. The messages i keep getting suggest that something is blocking the ports but i cannot figure out what that could be.

So yeah, for now the question is simply one of has anyone successfully got servers running a telephony application that has a softphone integration working and load balanced? And if so would you be able to offer some insight into how you got the softphone bit working please?

Thanks

Link to comment
Share on other sites

20 hours ago, Andrew Pilgrim said:

I am sorry this is a bit generic but for now it's a simple question. Has anyone has successfully got a softphone application to actually work via the Netscalers?

We have been asked to load balance our internal servicedesk phone system and i am running into issues because it has an integrated softphone feature.

I have got the basic load balancing of the web client sorted using HTTPS but i am running into problems trying to get the softphone integration working. I know this use's UDP protocol but i cannot get it to work.

I have tried setting up the virtual server as UDP protocol with ANY port allowed and tried that with both a Service group made up of the 2 physical servers as well as individual services for each server, again set up to allow ANY port and just does not work. The messages i keep getting suggest that something is blocking the ports but i cannot figure out what that could be.

So yeah, for now the question is simply one of has anyone successfully got servers running a telephony application that has a softphone integration working and load balanced? And if so would you be able to offer some insight into how you got the softphone bit working please?

Thanks

 

I would expect the IP telephony vendor to list what is required from the load balancing configuration (doesn't have to be specific NetScaler configuration, just general LB requirements). Perhaps it uses SIP protocol or requires some specific type of persistency, etc.

 

Hope it helps.

Link to comment
Share on other sites

On 9/1/2023 at 11:58 AM, Jeff Riechers1709152667 said:

I have run into issues with load balancing some web-based applications where they do a handshake and then they change the connection address in the stream to hit a server directly.

 

Can you run a wireshark trace on the machine and follow the traffic to see where it is trying to go when failing?

Tried wireshark and not very helpful. Also tried contacting the vendor and they are even less useful as they just say they have not tried deploying the application in a load balanced configuration.

I'll generate some output from wireshark and put it on here when i am back from leave and see if anything jumps out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...