Jump to content
Welcome to our new Citrix community!

Citrix ADC SSO not working with Sharepoint 2013 and Netscaler 13.0


Recommended Posts

Hello,

 

I have this client with 2 citrix ADC  installations. I want to scrap installation ONE and keep only installation TWO.

 

Installation ONE is physical appliance with ADC 13.1.4.44.nc and has an AAA TM form SSO with a Sharepoint 2013 site (working), through LDAP policy AD DC servers.

Installation TWO is virtual ADC 13.0-91.13 with AAA TM with many sites using form SSO (working), through LDAP policy AD DC servers

 

Sharepoint 2013 is connected to windows domain ALPHA

ADC TWO all destination servers are connected to windows domain BETA

Domain ALPHA and BETA are trusted

 

ADC ONE and TWO sites work both with ALPHA and BETA users. I have configured all AD DC in all ADC in the same way.

 

If I try to migrate this last site with Sharepoint 2013 in installation TWO, then the users get a Basic Auth request immediately after they log in the ADC AAA TM form authentication: this does not happen in installation ONE. If users put useraname and password in the basic auth (without the domain part), the site then works normally.

If I put installation TWO logs in debug I get this error, but can't see anything more of interest:

Aug 14 16:13:51 xxx.xxx.xxx.xxx 2023/08/14:16:13:22 netscaler1pri 0-PPE-0 : default SSLVPN Message 9215875 0 : "SSO Failed. Received 401/407 response in SSO_DONE State. Relaying 401 to client: auth type 3, author_hdr_removed - 2"

 

I tried messing with the LDAP server policies and Kerberos stuff, nothing worked so far.  Also I can't find release notes for 13.0 and 13.1 (I see only 14.1???)

 

Anyone using Sharepoint sites with ADC form AAA?

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...