Jump to content
Welcome to our new Citrix community!
  • 0

Workspace, multiple versions - App window not visible except through other app windows


Peter Fibæk

Question

Apologies for posting in Receiver 4.x forum, but there doesn't seem to be a forum for the Workspace app?

 

We've been using Citrix for more than 10 years now and recently (2 years ago) upgraded to Citrix XenApp 7.33 on the servers. (this problem has been existing for many years)

 

We've also gone through multiple revisions of the Workspace app with varying success.

So far we've determined that 2209 and 2305 are the two most stable versions with least amount of problems. 2305 is still under our review as it is fairly new, but it looks promising as the stable successor to 2209.

 

All other versions have their own quirks or problems, which makes them fairly useless in our environment.

Unfortunately I have not logged most of the quirks/errors in all the versions, as we usually just abandoned the version when we found a more stable one.

But we have been through almost all the various revisions between 2102 and the newest and 2209 has been the most stable till now.

2305 is promising though, but has the exact same issue that 2209 (and many other versions have).

 

::: 2305 - Seems stable, but has same "sometimes program-windows are hidden" issues that 2209 has. Good candiate for new stable version though, as no other issues have presented themselves yet.
::: 2210 - Same as 2207.
::: 2209 - Most stable version in our environment, but on occation some Citrix-program windows are not attached to its own client local window and only visible via another Citrix-programs local window.
::: 2207 - All existing apps sometimes becomes hidden after reconnecting to a session. App still runs, but cannot be called to the foreground and does not have its own Windows Taskbar icon. Visible only via other apps "window".

::: 2205 - Does not have the issue that 2209/2305 has with the "detached" app window, but has other more serious issues that I cannot remember right now.

::: LTSR 2203 CU1: Continually shows "Reconnecting / Abort" bottom right, even though apps launch correctly.
::: 2102 - Latest version that works in Windows 7/8
(2102 is legacy information, as we don't really have or support Windows 7/8 computers any more. Just remember to find and download NDP47-KB3186497-x86-x64-AllOS-ENU.exe and Windows6.1-KB4019990-x64.msu to make it work as they are not installed by default; just in case you find yourself in a situation where you need Workspace running on Windows 7 or 8)

---

 

Now on to the issue that seems to not have been solved in multiple workspace revisions.
 

billede.thumb.png.c054179b34120eb622f09c428280b1bc.png

The Word app is started from an attachment in Outlook. But it really doesn't matter if I start it from there or directly in the Workspace app. Same result. Sometimes the Word app just doesn't have its own window locally and must rely on the kindness of other apps in Citrix that does. As you can see on the screenshot, the Word app is ONLY visible through other apps windows.

If I go the the app, then the word app disappears behind the other programs and is no longer visible or controllable. I cannot tab-switch to the Word app, because locally it "does not exist".

 

When Word starts, the Word startminiscreen does appear in the middle of my screen (it clearly has its own window locally), but the main Word app does not.

billede.thumb.png.63c3f59a8e042056a9e83c362c7b1e5a.png

(All the icons at the top is because I locally run DisplayFusion to manage multiple apps, but users without Displayfusion also experience this issue)

 

Even the connection center does not have a record of the Word app running (because it does not have its own window, I assume):
billede.png.403024b58aef7ac6037349a461c63d60.png

The Citrix server (taskmanager under USERS tab) clearly shows the app running under my user:

billede.thumb.png.c00d716bbfad0795a6fdc21d0cbee841.png

 

So... something is preventing the app from having its own local window. But not always... Sometimes it works fine. It is a problem that comes and goes.

 

---

 

We use an install script to manage (re)installation and I hope it is not something in this script that is causing the problem.

I have attached a copy of the script (feel free to modify and reuse it). Just remember to alter the install command to fit your Citrix-system. It will not work out-of-the-box.

 

Citrix-Reinstall script.zip

Read the instructions at start of script.


It also cleans up after bad Citrix Receiver/Workspace installations, both using Citrix' own cleaner, but also runs some custom .reg files that I find cleans even more up than Citrix' cleaner.
Citrix uninstaller really leaves a lot of crap in the registry. (also true about many other programs, but here we are only concerned with Citrix)
In very rare cases you need to run the script 2-3 times for it to completely clean up a bad installation, but I've rarely had to do it more than three. 95+% of the time, it works on the first run.

If something goes wrong, the background turns red. If (re)install succeeded, it turns green.

Also remember to run it under an admin account and use "Run as Administrator".

 

These are the install parameters we use (change information within *** to fit your system):
/silent /noreboot /forceinstall /DeferUpdateCount=-1 /AutoUpdateStream=LTSR STORE0="***Storename shown in store list***;https://***subdomain.domain.com***/Citrix/***storename***/discovery; On; ***Storename shown to user***" ENABLEPRELAUNCH=True ALLOWSAVEPWD=N ALLOWADDSTORE=A SELFSERVICEMODE=True EnableCEIP=False DisableSetting=1 PutShortcutsOnDesktop=False

 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...