Jump to content
Welcome to our new Citrix community!
  • 0

We are trying to query the Citrix Cloud System log API and receiving 500 error


Nick Stone1709163929

Question

We have followed the documentation here https://developer.cloud.com/citrix-cloud/citrix-cloud---systemlog/docs/getting-started to query the SystemLog API.   We have created the Secure Client as described and have managed to connect to obtain the bearer token.

 

Issue we have is when we try to pull system log records, we receive a 500 error.  Need urgent assistance to resolve please.

 

{

    "oauth_token" => "eyJhbGciOiJSUzI1NiIsInR5c....",

       "@version" => "1",

        "message" => "Internal server error",

          "event" => {

        "original" => "{ \"statusCode\": 500, \"message\": \"Internal server error\", \"activityId\": \"b635ac9f-77d4-4c30-9ef8-d29744a341d3\" }"

    },

     "statusCode" => 500,

     "activityId" => "b635ac9f-77d4-4c30-9ef8-d29744a341d3",

     "@timestamp" => 2023-07-03T09:07:26.394539613Z

}

Link to comment

3 answers to this question

Recommended Posts

  • 0

Hi Nick,

 

You need to remove the "Accept: text/plain" header. You can try the below snippet for your customer.

 

curl --header "Accept: application/json" --header "Citrix-CustomerId: {cloud_custid}" --header "Authorization: CwsAuth Bearer={token}" https://api-eu.cloud.com/systemlog/records?limit=10

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...