Jump to content
Welcome to our new Citrix community!
  • 3

Update: VDAs 2303 --> 2305, WorkspaceApp: Desktops start (greyWindows) and immediately disappear


Jürgen Aufner

Question

after updating some VDAs 2303 to 2305 (W2022) and starting the Session in WorkspaceApp 2305 it starts (grey screen) and disappears immediately.

I have only updated one of our Machine Catalogs, the other ones (2303) still work.

 

VDA Eventlogs:

TdIca 1019, “The Citrix TDICA Transport Driver connection from xxx.xxx.xxx.xxx: to port 2598 received an invalid packet during its SSL handshake phase.”

 

Citrix Desktop Service 1050, citrix connection validation failed on domain “for user” for reason ‘hashexchangefailed’

 

I have once have had this after an update, new installation fixed it – but there should be a way to manage it without that. I expect this will happen also when I run the next update 230x.

Maybe someone has an idea?

 

kind regards

Link to comment

12 answers to this question

Recommended Posts

  • 0

unfortunately I could find a similar problem, but we use FsLogix (as main profile & office container).

 

here my findings:

update from VDA2212 -> VDA2305 (with ProfileMgmt latest Hotfix)

-> user login: FsLogix mounting profile.vhdx -> OK, CTX ProfileMgmt tries also to mount ProfileContainer.vhdx, session immediately logs off automatically

 

disable Citrix Profilemanagement:

--> user login: FsLogix mounting profile.vhdx -> OK

 

In CTX UPM log i can see the settings are fine, but UPM tries to load the container.
..
INFORMATION;;;;3208;ReadPolicy: Policy ProfileContainer disabled. Using an empty list.

INFORMATION;;;;3208;ReadPolicy: Configuration value read from Policy: FSLogixProfileContainerSupport=<1>
...

workaround, because we can't wait for a fix and need FsLogix and UPM both

- uninstall CTX UPM 2305

- install CTX UPM 2203 (2303 should also be OK)

Link to comment
  • 0

Hello Chirag,

I have used CWA 2305 days before with VDAs 2303. I have updated: Storefront to 2203 LTSR CU3, DDC to 2305 and finally some VDAs to 2305.  

Stefan wrote about Profile Mgmt. un/reinstall

No problem with setup, installation succesfull, everything looks good but ...

At the moment we have a "special" constellation with VMs created via SSVMM, VDA installed (no MCS) an therefore I dont want to install the  4 servers again.

 

Link to comment
  • 0

Hello Chirag,

we had the issue when we update VDA to 2305 and we solved it with uninstalling UPM 2305 and installing UPM2203. I'll create a support case next weeks.

My comment was just a info for users which use FsLogix and UPM 2305 with FSLogixProfileContainerSupport enabled.

But i'm sure that not much users use both as we did. (because there was a problem from UPM2212 and first version of UPM2303 until fix and couldn't find anything at that time in any forum, etc., case 81614246 -"Profile Mgmt V2212 with FSLogixProfileContainerSupport delete ntuser.dat in.vhdx")

 

I'll create a support case next weeks for VDA2305/UPM2305 and FSLogixProfileContainerSupport.

Link to comment
  • 0
On 6/14/2023 at 2:21 PM, Jürgen Aufner said:

after updating some VDAs 2303 to 2305 (W2022) and starting the Session in WorkspaceApp 2305 it starts (grey screen) and disappears immediately.

I have only updated one of our Machine Catalogs, the other ones (2303) still work.

 

VDA Eventlogs:

TdIca 1019, “The Citrix TDICA Transport Driver connection from xxx.xxx.xxx.xxx: to port 2598 received an invalid packet during its SSL handshake phase.”

 

Citrix Desktop Service 1050, citrix connection validation failed on domain “for user” for reason ‘hashexchangefailed’

 

I have once have had this after an update, new installation fixed it – but there should be a way to manage it without that. I expect this will happen also when I run the next update 230x.

Maybe someone has an idea?

 

kind regards

 

Hi,

same issue after update to 2203 LTSR CU3 from 2203 LTSR CU2. All other VDA using 2203 CU2 still work. I have Windows 2022 Standard as operating system. Reverting a vmware snapshot with 2203 LTSR CU2 works again without problem. StoreFront are 2203 CU3, Delivery Controller 2203 CU3. The issue seems to be related to VDA CU3 because same enviroment with CU2 works without problems.. Thanks in advance for any answer. 

Kind regards, 

Fabio.

Link to comment
  • 0

Hi @Jürgen Aufnerand  Stefan,

 

Sorry for the delayed response. We are aware of the issue and are working on fixing it as soon as possible. Meanwhile please go through this article for more details and a solution while we get the issue fixed - https://support.citrix.com/article/CTX560646/virtual-appdesktop-sessions-fail-to-launch-with-citrix-workspace-app-2305-for-windows


Sorry for the inconvenience caused.

 

 

Link to comment
  • 0

Goodmorning,

 

I just found this discussion about the gray screen/disconnect issue.

We are also experiencing this issue, but not with VDA 2305 but with VDA 2303 and Workspace 2303 and 2212, our DDC's are running CVAD 2303.

 

The https://support.citrix.com/article/CTX560646/virtual-appdesktop-sessions-fail-to-launch-with-citrix-workspace-app-2305-for-windows page says te revert back to 2303, but in our case this isn't an option. I have read in this discussion that Stefan Wielers had fixed the problem with installing an older version of UPM. So I am going to test if this also will fix it for us, but in my case I will try to disable UPM in de image first because with don't use UPM in our image but it's enabled, expect for the login times. After that I will try using an older version of UPM.

 

Have there been others with the same issue on VDA 2303?

 

Kind regards,

 

Stef

 

Link to comment
  • 0

Hello again,

in my case the WorkspaceApp 2305 is not the problem, okay even it is no longer available so not supported.

 

I made a Test:

Installation of new VM via MS SCVMM Windows 2022 Server, MS updates, VDA 2303, Optimizer Tool, WEM Agent 2303, MSApps365, etc. -  DDC: create Machine Catalog and Delivery Group.

Start the Desktop via WorkspaceApp 2305 -> it works

So I made an snapshot and update to VDA2305, uninstall PM2305 via PS - restart, install PM2305 - restart

Start the Desktop ... ->  Display (grey) shortly appears and closes immediately

 

But if I make a new VM with VDA2305 installed I get no problems, the Desktop works - what is the problem or my fault???

 

kind regards,

 

Juergen

Link to comment
  • 0

Hi,

I already had the issue updating from 2203 LTSR CU1 to CU2 and now again from CU2 to CU3 (on Windows Server 2022).

Back then (from CU1 to CU2) I got it working by basically uninstall and reinstall the VDA. I followed the seven steps procedure on Jakob's post (https://discussions.citrix.com/topic/417832-cvad-connectionfailure-after-install-ltsr-2203-cu2-on-server-2022/page/3/).

Now (from CU2 to CU3) I got it working just by running the cleanup script (see Jakob's post) after the upgrade to CU3. 

Unlike what Citrix is support is saying, this is clearly not a Workspace issue. 

Citrix is messing with VDA updates since 2203 LTSR CU2 (on Windows Server 2022).

 

Regards

 

Helpdesk

Link to comment
  • 0

Hi,

 

i got the same problem, except i do not get an error in the event log on the vda. The session is active on the vda but the workspace app is not showing a connection and the opened app is an empty window.

Im on Windows Server 2016. The suggested script is not finding any entrys in the registry.

I used the vda clean up tool and installed VDA 2305 from scratch.

Every VDA Version below 2305 is working.

Any more ideas?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...