Jump to content
Welcome to our new Citrix community!

Too Many Redirects post 13.1 upgrade


Recommended Posts

After upgrading our VPXs to 13.1, any remote user trying to connect with our Access Gateway through a web browser is getting the error "you've been redirected too many times". Everything else appears to be working as it should, including the Workspace client.

 

Authentication is working on the web Receiver, it's right after that when the user gets the error. I noticed in the Chrome inspector, there are several 302 errors (object has been moved).  No changes have been made to the config, other than the upgrade.

 

Note: We do have some classic session and authentication policies in use, but everything passed the nspepi and check_invalid_config utltities.

 

Any thoughts on what could cause this error?

Link to comment
Share on other sites

On 5/30/2023 at 10:16 AM, Carl Stalhood1709151912 said:

Make sure your Session Policy expressions don't have any Referer clauses.

 

Turns out we did have a Referer clause in one of our session policies. Removing this seems to have resolved the redirect issue.

 

I greatly appreciate the suggestion, Carl!!

 

Do you know why the referrer statement caused this to happen?

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...