Jump to content
Welcome to our new Citrix community!
  • 0

%localappdata% cannot be used properly


Question

Hello everyone,

 

I have the following problem. We use VAD 7 1912 LTSR CU2.
Applications are installed in the VDI that write data to the %localappdata\Temp directory and other programs access it. That does not work. Before switching from Citrix 6.5 to 7.x, this worked perfectly.
Scenario: Within a program, the messages can be written in an embedded e-mail tool and by pressing Send this .eml file + any attachments are stored in the C:\Users\%username%\AppData\local\Temp directory
written and should then actually be opened by the standard app, in our case Outlook, in order to then adapt further formatting and formulations. There are several more examples that don't work.
As soon as one program writes something in the Temp directory and another wants to process and use it, nothing works. The file is created, but then nothing else happens.
I have already added the path to the exclusions in Windows Defender - no change. I also created a localappdata.txt in C:\Program Files\Unidesk\Uniservice\UserExclusions with path C:\Users\*\AppData\Local\Temp\.
All this does not bring the hoped-for solution.
What else can I do to finally get rid of this problem?

Link to comment

3 answers to this question

Recommended Posts

  • 0
34 minutes ago, Jeff Riechers1709152667 said:

What are you using for your profile system?  Some redirect that directory to a non-volatile location.

 

Are you using App Layers?

I have currently set the storage location to the home drive of each user. The problem with this solution, however, is that it leads to more crashes.

 

Yes i am using App Layers. I 'm sorry. I'm new in this topic.

Link to comment
  • 0

Hello again,
Today I had the idea to start the master image directly in the VCenter and log in with the local administrator. I started the program and tried to send an e-mail from it. What can I say? As soon as I clicked Send E-Mail, the default e-mail program (Office Outlook) opened almost immediately. So my assumption is that it is only due to the layering or the user layer. How can I rule out that this problem occurs in the VDI?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...