Jump to content
Welcome to our new Citrix community!
  • 0

Gracefully closing published application does not log off user


shussai409

Question

This is our environment,
 

  • VDA version = 1912 LTSR CU6
  • OS = Server 2012 R2, 2019
  • Only published applications
     

The following issue occurs on the Server 2019 VDAs only.

When a user closes a published application, session state remains Active but Application State changes to Application not running.
Citrix1.png.7c9621f8a4129882e1e0caa335dc83a7.png
If the user logs off on the Storefront website, the session state changes to Disconnected, while Applicaton state remains Application not running.

If I check which processes are still running for the user, these are the culprits,
Citrix3.thumb.png.fc2db123cc1fa4b6768a078a88c794e6.png
 

If I manually close CtxMTHost.exe and Wfshell.exe, the user gets logged off. Only closing one of them does not log the user off.

I have tried to add all of these processes to LogoffCheckSysModules in registry, but to no avail.
I started by adding just "CtxMtHost.exe,wfshell.exe", but that did not yield any results, so I added all of them just to test.

https://support.citrix.com/article/CTX891671/graceful-logoff-from-a-published-application-renders-the-session-in-active-state


ccSvcHst.exe,DirectorComServer.exe,fontdrvhost.exe,ctxgfx.Exe,icak2meng.exe,CtxMtHost.exe,wfshell.exe
Citrix4.thumb.png.9e15c7ce466aab19537dbadaeff5800f.png

Does anyone have experience with this issue?

Link to comment

2 answers to this question

Recommended Posts

  • 0

You are on the right path in terms of 1 of the processes is keeping the session alive preventing it from logging off properly.  I would first suspect the Symantec process hthat is in the session and try these steps. https://support.citrix.com/article/CTX121599/an-active-session-exists-even-after-logging-off-the-session-when-symantec-endpoint-protection-is-installed-on-a-citrix-xenapp-server  

 

Registry Key: HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Citrix/wfshell/TWI

Value Name: SeamlessFlags

Value Type: REG_DWORD

Values: 0x20 (this is the flag for the DISABLE SYSTRAY AGENT)

 

To avoid multiple instances of the SmcGui process the SEP tray icon, disable SmcGui by setting the following DWORD registry value on the Terminal Server:
HKLM\SOFTWARE\Symantec\Symantec Endpoint Protection\SMC\LaunchSmcGui = 0

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...