Jump to content
Welcome to our new Citrix community!
  • 0

FSLogix - ProgramData\FSLogix\Cache - Filling up fast!


David Ashcroft

Question

So we've recently started implementing FSLogix for our Citrix platform. It seems to be working well, user settings are being retained which is great.

 

We're using CloudCache for high availability. Our Citrix non-persistent desktops have approx 12GB of free space available when a user logs in. As we would expect, the local cache data does begin to increase in size as data is written to and from the VM and back to the VHD.

 

However... We seem to be getting some users where the entire 12GB free on the VM is being taken up, bringing the VM to a complete halt. After checking on this a little more, it seems that the disk inside ProgramData\FSLogix\Cache is the cause of the increase. 

 

I've done a bunch of testing around this, and everything seems to work comfortably, until our users open Outlook! Once Outlook is opened, the size of the cache directory just seems to slowly increase up to the point where there is no space left! 

 

We have forced cached exchange mode, with 1 year of mail cached. I'd possibly expect this to happen during the initial sync of the Outlook OST file, as I'm sure the reads and writes would end up filling the FSLogix cache during the initial sync. However, even after the initial sync is complete, the Cache VHD just seems to slowly creep up over a couple of hours until the VM disk is full.

If I close Outlook, the increase seems to immediately stop.

 

I was wondering if anyone else has experienced this? Do we just need to increase the disk sizes of each VM, is more than 12GB recommended as a buffer in some cases? Anything else I can perhaps change or do so that the cache VHD doesn't go over a certain size?

 

Important to note that we have approx 250 users running over FSLogix now, and approx 10 people have reported the issue, so it certainly isn't happening to everyone all the time. Though it's affecting people enough that we're going to need to resolve this before rolling this out to the entire business.

 

Thanks in advance.

 

(2 images attached, shows the size of the cache at the start of the session vs just over 1 hour in)

 

2023-05-03_21h36_04.png

2023-05-03_22h46_48.png

Link to comment

4 answers to this question

Recommended Posts

  • 1

Create a larger writecache disk, and set the Cache directory to reside on that volume.

 

If people have large profiles you have to provide enough space to support them.

 

Are you using redirections.xml to restrict data in the profile?  Is there any other temp directories you can exclude from the profile to shrink it?

 

Also why is there a full year of outlook data cached?  The most I will allow clients to have is 3 months, anything older will be accessed off of the Exchange Servers.

  • Like 1
Link to comment
  • 0
20 hours ago, Carl Stalhood1709151912 said:

Thank you for this, I tried putting the reg keys in last night in the following 2 locations:

HKEY_LOCAL_MACHINE\SOFTWARE\FSLogix\Profiles\CCDMaxCacheSizeInMbs
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\FSLogix\ODFC\CCDMaxCacheSizeInMbs

 

I set the size for both to 6000, which I thought would be 6GB.

 

However this morning we've had 50+ calls of people being unable to work due to sessions being so slow that they're unworkable. I removed on and confirmed this myself too.

 

Even though it's been set to 6GB for the limit, it seems to be limiting the cache to a very small size, and even the size isn't correct. You can see it seems to be limiting the size to 192MB, even though this users VHD on the server is approx 6GB.

 

If I remove the two reg keys above, it seems to return to normal, although we're then faced with our original issue again whereby the cache size is growing too big... Very strange... Again though, any advice is appreciated.

2023-05-05_11h46_42.thumb.png.975f07ff284034c14a305bd37fd472de.png

 

 

Link to comment
  • 0

You need to be careful with that setting above, its a per user configuration and will impact performance https://learn.microsoft.com/en-us/fslogix/reference-configuration-settings?tabs=ccd#ccdmaxcachesizeinmbs

 

Agreed with above really, you need to have the capacity to handle local caching of the profiles and that needs to be on very fast disk - that is something often missed when using CC

 

As an FYI, you should make the change on the master/gold image because it won't work if you try and do it via GPO after provision....race condition 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...