Jump to content
Welcome to our new Citrix community!
  • 0

Issues with Cloud Monitor API - Failure after first 100 rows returned


TIM GARDNER

Question

We have a process that pulls data from the Citrix Cloud using their REST API.  Within the past few days something seems to have changed on the Citrix side that is preventing us from getting anything more that the first 100 rows of a query.  Nothing has changed on this side but at 2023-04-02T22:58:55.690-05:00, the "NextPage" value changed from https://api-us.cloud.com/monitorodata/Connections?$skip=565300  to  https://[CustomerId].xendesktop.net/citrix/monitor/odata/v4/data/Connections?$skip=565400 instead of https://api-us.cloud.com/monitorodata/Connections?$skip=565400.  After this we get a 401 error and it fails.  Now, any time we run this process, after the first 100 rows are returned, it changes the NextPage value to the longer format with our CustomerId included and then fails immediately with the Unauthorized error.

 

I do not see any updates under https://developer.cloud.com/citrix-cloud/citrix-cloud-api-overview/docs/citrix-cloud-api-walkthrough and I verified the creator of this API is still a Full administrator in the site.  If anyone else is experiencing similar issues or has solved this problem, please let me know.

Link to comment

3 answers to this question

Recommended Posts

  • 0

We are seeing the same issue in our environment.  No changes on our end, but the api gateway is redirecting to [customerid].xendesktop.net rather than using api-us.cloud.com.  We are using a PowerShell script similar to Citrix documentation with a recursive function built-in.  It's worked great for a long period of time and has only recently started to fail.

 

Here's the error we receive:

 

Access denied to query Monitor objects : Authorization or Customer header is unavailable.

    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException

Link to comment
  • 0

We were able to get a solution to this issue through our TAM's contact with Engineering.  The solution is simple, if your CustomerID is in mixed case, change the value to all lower case in your API call.  I know this makes no sense and it was not included in the developer notes on the API, but after we changed ours, it immediately started working again.  We went back to logs and found that this broke for us during a job that was running successfully until 2023-04-02 at 22:58 CDT.  Every run after that failed after the first 100 rows.  Seems like some programmer on the API decided that mixed case was not allowed and that using it would just generate a bogus NextPage value as punishment...  Makes no sense since Citrix allows mixed case when you create the CustomerID initially when you define the Citrix Cloud site. 

Hope this works for you.  Sorry for the slow response, I just saw this post.  Evidently Citrix does not monitor this site even though they claim this is the method for getting help on the API.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...