Jump to content
Welcome to our new Citrix community!
  • 0

LTSR 2203 VDAs Unregistering for a Second.


H Desk

Question

Hi,

 

We recently upgraded to LTSR 2203 CU2 from 1912 CU5 and have been experiencing problems with VDA servers randomly deregistering from one delivery controller and registering to another. The process only takes a second and doesn't cause any issues, but it generates an alert in Director which isn't pretty to look at. Understandably, people question if there is a bigger problem when repeated errors like these are seen.

 

The Delivery controllers, StoreFronts and PVS servers are Windows 2016 and LTSR 2203 CU2. The machine catalogue and delivery group have now been upgraded to 2106. The VDA servers are Windows 2019\LTSR 2203 CU2.

 

After upgrading the DLC, SF and PVS servers, some of the VDA servers were still running LTSR 1912 and did not experience the problem. Now that they are all 2203, they all get the error at some point.

 

The problem starts when the servers are under load, usually from 9am onwards. It doesn't occur for a delivery group where the VDAs are still on LTSR 1912 CU5, but these servers are moderately loaded.

 

On the VDA server we see two events:

1048, The Citrix Desktop Service is re-registering with the DDC: 'NotificationManager:NotificationServiceThread: WCF failure or rejection by broker
1010, The Citrix Desktop Service successfully obtained the following list of 2 delivery controller(s) with which to register

 

There are no unusual events on either delivery controller and there are no network connectivity issues according to PRTG.

 

I have tried uninstalling the VDA and reinstalling it.

 

I found another thread from 2017 which had the same problem (which was for an older version of course) the solution in that case was a hotfix that replaced rpm.dll.

 

Thanks,

Link to comment

2 answers to this question

Recommended Posts

  • 0

This problem, and quite a few others, appear to have been solved by adding the registry keys below, which I found in a Reddit thread:

 

Path: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect
Name: FastReconnect
Type: REG_DWORD
Value: 0

Name: DisableGPCalculation
Type: REG_DWORD
Value: 1

 

Path: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Ica\GroupPolicy
Name: EnforceUserPolicyEvaluationSuccess
Type: REG_DWORD
Value: 0

Link to comment
  • 0

Do you have installed Citrix profile management? If so, which version?

Check the eventlog on the VDA if you find an "application error" with isessionmetrics.exe

I had the same Problem after updated to 1912 LTSR CU06 and the profile management was an older, non LTSR Version.

 

https://docs.citrix.com/en-us/profile-management/1912-ltsr/whats-new/cumulative-update-5/fixed-issues.html -->  CVADHELP-18713

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...