Jump to content
Welcome to our new Citrix community!
  • 0

Upgrade 7x to 8.2 - won't exit maintenance mode - "nonetype' object has no attribute 'opaqueRef"


jon yeargers

Question

The upgrade appeared to be successful in that the host came up and reported the correct version.

 

Unf it appears to be stuck in maintenance mode. Attempts to take it out via console give the error ("'nonetype' object has no attribute 'opaqueRef'",)

 

Attempts to remove it from the current pool fail.

 

Im assuming that something got misconfigured in the upgrade process but I have no clue where to look.

 

All network settings are correct. 

 

 

-----

 

These from /var/log/xensource.log:

 

 

Mar 20 08:08:33 xen1 xapi: [debug||0 |dbsync (update_env) R:7614b73b0ec8|dbsync] creating domain 0

Mar 20 08:08:33 xen1 xapi: [error||0 |dbsync (update_env) R:7614b73b0ec8|helpers] Failed to find domain zero (uuid = 16ed144f-815e-4119-be6c-8d598976a2ea)

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] dbsync (update_env) R:7614b73b0ec8 failed with exception Db_exn.DBCache_NotFound("missing column", "VM", "NVRAM")

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] Raised Db_exn.DBCache_NotFound("missing column", "VM", "NVRAM")

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 1/12 xapi Raised at file ocaml/database/db_rpc_client_v1.ml, line 33

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 2/12 xapi Called from file ocaml/xapi/create_misc.ml, line 300

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 3/12 xapi Called from file ocaml/xapi/create_misc.ml, line 238

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 4/12 xapi Called from file ocaml/xapi/create_misc.ml, line 213

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 5/12 xapi Called from file ocaml/xapi/dbsync_slave.ml, line 235

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 6/12 xapi Called from file ocaml/xapi/dbsync_slave.ml, line 275

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 7/12 xapi Called from file ocaml/xapi/dbsync.ml, line 67

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 8/12 xapi Called from file ocaml/xapi/server_helpers.ml, line 95

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 9/12 xapi Called from file ocaml/xapi/server_helpers.ml, line 121

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 10/12 xapi Called from file lib/xapi-stdext-pervasives/pervasiveext.ml, line 24

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 11/12 xapi Called from file map.ml, line 135

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace] 12/12 xapi Called from file src/sexp_conv.ml, line 156

Mar 20 08:08:33 xen1 xapi: [error||0 ||backtrace]

Mar 20 08:08:33 xen1 xapi: [debug||0 ||dbsync] dbsync caught an exception: INTERNAL_ERROR: [ missing column; VM; NVRAM ]

Mar 20 08:08:33 xen1 xapi: [debug||0 ||xapi] Failure in slave dbsync; slave will pause and then restart to try again. Entering emergency mode.

 

 

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...