Jump to content
Welcome to our new Citrix community!

Audio Devices disabled


sortola27

Recommended Posts

When remoting in over our Netscaler, the remote session (terminal server or physical pc) shows all the output and input audio devices as disabled. We have to go manually enable our speakers and headsets to get them to work again.

 

Any ideas on how to get these to enable by default?

Link to comment
Share on other sites

  • 2 weeks later...

Neither I believe.

We're logging into the gateway and then starting an ICA session direct to a PC with the Virtual Delivery agent installed.

I've recently noticed this happens on my desktop PC, but it doesn't on my laptop.  Both have the same version of Receiver installed. 

Link to comment
Share on other sites

 

This might be a local client setting then in the citrix workspace app.

Since you can enable the setting, the virtual channel is enabled, just starting OFF on your local system.

And since the behavior is different for one device (PC) vs. laptop, which I assume are both windows, I think its the local client settings.  It also might be the difference betwen on domain vs. non domain device.  

 

I may not have a device until Monday to Look at the exact value on this. If you right click on your Citrix Workspace App, you may  get to a set of settings for local devices like 

https://support.citrix.com/article/CTX133565/how-to-configure-default-device-access-behavior-of-workspace-app-for-windows

 

You may have just have clicked the "No Access" option during the first request on the one device and so it defaults to disabled audio until you manually enable. As opposed to "permit use of device".  Second screenshot in the above article shows this.

 

If you go into the Workspace App or its Connection Center while in session, I think there is a place where you can change this.

Otherwise, the reg keys at bottom of article may help with the local fix.

 

If its for a wide number of users experiencing this behavior and not just a one off, look in CVAD to see if there is a policy in effect for gateway vs. non-gateway or domain vs. non-domain joined systems.  But This feels like the local preference to me.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...