Jump to content
Welcome to our new Citrix community!
  • 0

Finalize Layer Error: The disk structure is corrupted and unreadable


Darryl Sakach

Question

I uipdated several  layers yesterday with no issues. Today I am updating an Edge layer that I worked on yesterday. I keep getting the error below. I have tried starting with an older base but still get the error.

 

An error occurred while finalizing version... of Layer... on Packaging Machine... Please address this issue and retry: "The disk structure is corrupted and unreadable"

 

Any ideas on what may be causing this? Creating the packaging and updating it all goes fine, it is just the finalizing that fails.

 

This is what I am seeing on the ELM console:

 

image.thumb.png.51bf2e2bda14fef7df09df84190c3703.png

Link to comment

2 answers to this question

Recommended Posts

  • 0

Solved. There was no free storage. I had to go to Monitoring and Storage to find that out. I cleaned up some old versions and all is working again.

 

A better error message would be appreciated. Active monitoring of the free storage would also be helpful with notification via email, similar to the memory warnings I sometimes get from the appliance.

 

 

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...