Jump to content
Welcome to our new Citrix community!
  • 0

2203 LTSR CU2 - BSOD on pdcrypt2.sys


Martijn

Question

Hello,
 

Since our upgrade to CU2 we get this about every other week on several servers. There is a support article here but it dates back to an earlier release in 2018 and should be fixed.

 

So this is 2203 LTSR CU2 on W2019. I don't think I ever saw this with CU1 but I'm not sure.

 

 

Capture.PNG

Link to comment

6 answers to this question

Recommended Posts

  • 1
On 2/10/2023 at 3:27 PM, Martijn Kools1709163625 said:

Hello,
 

Since our upgrade to CU2 we get this about every other week on several servers. There is a support article here but it dates back to an earlier release in 2018 and should be fixed.

 

So this is 2203 LTSR CU2 on W2019. I don't think I ever saw this with CU1 but I'm not sure.

 

 

Capture.PNG

We are also seeing this issue and have a support case ongoing, We did receive an unsigned version of the pdcrypt2.sys that seems to be stable. Currently awaiting a private fix for this issue

  • Like 1
Link to comment
  • 0
On 2/10/2023 at 10:39 PM, Jeff Riechers1709152667 said:

Are you using SecureICA?  If you are secured behind a NetScaler you can just set that to basic and it should prevent this driver from crashing.

 

You are right SecureICA is indeed enabled. I've disabled that now hopefully this will solve the issue.


Thanks a lot!

Link to comment
  • 0
3 hours ago, STIG BAKKE1709151646 said:

We are also seeing this issue and have a support case ongoing, We did receive an unsigned version of the pdcrypt2.sys that seems to be stable. Currently awaiting a private fix for this issue

 

Good to hear I'm not the only one. It doesn't happen a lot but every time is one time too many. I have at least one server crashing each week. I don't even know why we had Secure ICA on in the first place so I just disabled it. My predecessor did that but we are by no means a bank or anything so I will just keep it disabled for now. It will probably be fixed in CU3 as I assume they had more support calls about it.

 

Link to comment
  • 0

Hello,

we have the same problem in this week on several windows 2016 servers with CU2.
We also have "Enabeld" the  "Secure ICA " feature in the propertys of the delivery groups.

Now I will disabled the feature and hope this is a workaround and it will be fix with 2203 CU3.

 

image.png.1f46e89d9dff887eb39f9af5ef181c1f.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...