Jump to content
Welcome to our new Citrix community!
  • 0

SSON is not working in Workspace app 2212 version


Question

Hi Experts and Citrix team,

 

After upgrading our Citrix Workspace app to 2212, single sign-on is failing. Below are the steps I tried to reproduce the issue,

 

>Very first I upgraded to workspace app version 2212

>Rebooted the VDI
>After reboot I connected to my VDI  and tried to login in Workspace app,  it asked the login credentials, logged in and rebooted

>After reboot, connected to the VDI and tried to login again but asked for the credentials ((SSON failed))

>Then uninstalled workspace app 2212 and rebooted
>Installed 2210 and then rebooted again
>Connected to the VDI, logged in again and tried to login in Workspace app

>Smoothly logged in the workspace app ((SSON Worked))

Link to comment

2 answers to this question

Recommended Posts

  • 0
7 minutes ago, Muhammad Quaseem Noor Siddiqi said:

Hi Experts and Citrix team,

 

After upgrading our Citrix Workspace app to 2212, single sign-on is failing. Below are the steps I tried to reproduce the issue,

 

>Very first I upgraded to workspace app version 2212

 

 

Hey Muhammad,

You're saying you're "upgrading" your CWA to 2212... is it actually an upgrade ie from 2210 to 2212 or is it a fresh 2212 install? (if its an upgrade have you tried a fresh install? your notes above look like you did a 2210 to 2212 upgrade and then did a 2210 fresh install but never a 2212 fresh install?)

 

Also when installing 2212 are you using any command line parameters?

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/install.html

 specifically :

/includeSSON

ENABLE_SSON=Yes

Link to comment
  • 0
3 hours ago, Bruce Coleman1709158411 said:

 

Hey Muhammad,

You're saying you're "upgrading" your CWA to 2212... is it actually an upgrade ie from 2210 to 2212 or is it a fresh 2212 install? (if its an upgrade have you tried a fresh install? your notes above look like you did a 2210 to 2212 upgrade and then did a 2210 fresh install but never a 2212 fresh install?)

 

Also when installing 2212 are you using any command line parameters?

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/install.html

 specifically :

/includeSSON

ENABLE_SSON=Yes

 

Hi Bruce,

 

Appreciate your reply. I have tried to install CWA from scratch as well but still no luck.

 

So I uninstalled 2210 and rebooted the VDI. Connected the VDI again and made sure no CWA is there. Then installed CWA 2212 and then rebooted after installation. Connected the VDI again and when tried to login in my CWA it failed to connect through SSON and asked for credential. I logged-in in CWA by passing the credentials and then again rebooted to check the behavior. After reboot connected again but same result, it is asking for credentials.

Also, both the versions I installed via GUI and selected the Single Sign On option while installing. Attaching the screenshot for reference.

 

CWA.jpg

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...