Jump to content
Welcome to our new Citrix community!
  • 2

Windows 11 taskbar when running virtual app


Matthew Gehlhausen

Question

10 answers to this question

Recommended Posts

  • 0

We are seeing this as well so far on physical machines. If you click on the open apps on the taskbar it will not bring that app forward, you can alt-tab to get to the apps. As soon as you close any open citrix app it works fine again. We are using workspace LTSR 2203 CU2. It seems to work alot better if you change the taskbar to left aligned versus center. We also have w365 cloud machines and when i test the same scenario we do not see the issue. I wasnt sure if this was a microsoft or citrix issue but leaning towards citrix but will start with a citrix ticket.

Link to comment
  • 0
On 2/9/2023 at 12:11 PM, Chris Bulau1709163149 said:

We are seeing this as well so far on physical machines. If you click on the open apps on the taskbar it will not bring that app forward, you can alt-tab to get to the apps. As soon as you close any open citrix app it works fine again. We are using workspace LTSR 2203 CU2. It seems to work alot better if you change the taskbar to left aligned versus center. We also have w365 cloud machines and when i test the same scenario we do not see the issue. I wasnt sure if this was a microsoft or citrix issue but leaning towards citrix but will start with a citrix ticket.

 

Did you end up opening a ticket? Anything become of it? We're seeing this as well with 2203CU3 Workspace client on Win11 Azure AVD sessions.

Link to comment
  • 0

Opened a ticket:

 

Issue resolved after following the below workaround:
1. On your workstation, make the following registry changes:

- (For 64 bit): HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\GfxRender\UseD3DHybrid to value 0

- (For 32 bit OS): HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\GfxRender)

2. The registry value "UseD3DHybrid" should be of the value DWORD.

3. Restart the workstation

 

NOTE: Please test the above reg change on a test machine first. 

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

 

The workaround worked for me for:

 

Workspace: 22.3.2000.2105 LTSR

Windows: Win11 Enterprise 22H2

 

Best regards!

Link to comment
  • 0

Seeing the same issue in:
Workspace: 23.3.0.55(2303)
Windows: 11 E. 22H2

Solution above from Swjatoslaw Gordiychuk helped!   But we can not reproduce the error so no case made towards CITRIX.

And we will not deploy this fix in general, so our support will have to apply the fix individually for users that report on the problem.

Link to comment
  • 0
4 hours ago, Jan OEstergaard said:

Seeing the same issue in:
Workspace: 23.3.0.55(2303)
Windows: 11 E. 22H2

Solution above from Swjatoslaw Gordiychuk helped!   But we can not reproduce the error so no case made towards CITRIX.

And we will not deploy this fix in general, so our support will have to apply the fix individually for users that report on the problem.

 

FWIW, I don't believe there is any error thrown for this issue. The taskbar just becomes unresponsive after launching a published application.

 

We too opened a ticket and came back with the same registry workaround which worked for us as well. The last support said was the issue may take a while to resolve in a release since they speculated they'll probably need to collaborate with Microsoft. That was quite a while back now though so I'm not sure where that stand.

Link to comment
  • 0

The fix mentioned also worked for us for workspace app.  
 

however we have a similar issue when using outlook 365 monthly enterprise from within the windows 11 multisession avd desktop.  The taskbar hidden icons cannot be selected until outlook is closed.  Other office apps don’t have the problem and also semi annual channel also does not have this issue.  
 

Is anyone using windows 11 multisession 22h2 with office 365 monthly and not having this issue with outlook ?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...