Jump to content
Welcome to our new Citrix community!
  • 0

GRID Desktops displaying "grey bars" after recent updates


Mick Swanson

Question

We've got a slew of virtual desktops running NVIDIA GRID (Tesla T4) cards on Server 2019 and 2022 (Running a few different VDA versions, mostly 2203.1) that in the past few days suddenly won't scale their resolutions to match the CWA window in fullscreen, and sessions appear as a small window with a large frame of "grey" around it. The sessions run okay in windowed mode, but I believe they still won't scale past a certain size. This behavior is very reminiscent of selecting the wrong scaling mode while running monitors with mixed resolutions.

 

What we think might be happening is a windows update is causing the OS to use a Microsoft Basic Adapter instead of the NVIDIA GRID card as the display adapter. We haven't yet been able to confirm that it's doing this because we've been too busy rolling everyone back to a snapshot from a few days prior to keep them working and haven't had time to sit down with one of these broken machines for a while. Update: I hopped on a broken machine this morning to test, and going to Advanced Display Settings, it appears it is using the NVIDIA Tesla T4 card as the display adapter, NOT the Microsoft adapter like we anticipated.

 

We have not made any big sweeping changes right before this broke, but we did notice that there were some Windows updates installed late last week (we're on a 30 day delay for Windows updates) that fit the timeline of things breaking. Reading through the KB articles it doesn't appear that anything in them would cause this. Regardless - The KBs maybe in question:

 

Server 2019 Updates

  • December 13, 2022—KB5021237 (OS Build 17763.3770)
  • December 13, 2022-KB5021085 Cumulative Update for .NET Framework 3.5, 4.7.2 and 4.8 for Windows 10, version 1809 and Windows Server 2019

 

Server 2022 Updates

  • December 13, 2022—KB5021249 (OS Build 20348.1366)
  • December 13, 2022-KB5021095 Cumulative Update for .NET Framework 3.5, 4.8 and 4.8.1 for Windows Server 2022

 

Update: Just this morning on one of the previously rolled back 2019 machines, KB5021237 had reinstalled itself and the problem was back. I tried uninstalling that update (It took forever, 30+ minutes) to see if it would resolve, but the problem remained. I believe the problem is caused by this update, but rolling it back doesn't seem to fix it. I rolled back the VM to a working snapshot again and used the Windows show/hide update tool to hide KB5021237. Time will tell if that does the trick or not.

 

Things we've already checked off the list as non-fixes:

  • Scaling/High DPI modes
  • CWA version / clean install
  • GRID driver reinstall on VDA
  • Launching the session from my own machine to make sure it isn't the endpoint
  • Rolling back Windows Updates

 

What has worked so far:

  • On one Server 2022 machine, a "Microsoft Remote Display Adapter" was present in device manager. Uninstalling this resolved the issue. It has not worked for many others - Uninstalling this does not fix the issue. On many, this adapter is not present in device manager.
  • Rolling back to a snapshot from the start of the prior business day.

 

Anybody else experiencing this? I know running GRID cards on a Server OS is pretty niche, but hoping someone might have some info to help us track this down.

Link to comment

2 answers to this question

Recommended Posts

  • 0

This issue still comes up occasionally, but we found a fix for it in a really weird place. It's reliably worked for us whenever this has come up again, as it does for a few users every few months.

 

tl;dr: this happens when the Windows Management Instrumentation service breaks for whatever reason. Fix is the batch file below.

 

How I figured it out:

We noticed a commonality that the users who would get this issue would also get an error "RevitWorker.exe was not found" when trying to launch Revit. That led me to this Autodesk knowledgebase: https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Error-RevitWorker-exe-was-not-found-at-launching-Revit-program-crash.html

 

In the linked article, the first "Windows Issue" listed is that the WMI service is broken, which you can check for by launching msinfo32.exe. If it "can't collect information", you've got this issue. I can't recall exactly how I put 2 and 2 together here, but I think I found in event viewer somewhere that the Nvidia WMI service was crashing or failing to start.

 

The Fix:

Autodesk provides the following script to get the Windows WMI service running again. This fixes our "grey bars" issue. I don't believe you even need to reboot, simply resizing your session window will start working immediately. If that doesn't work, of course give it a reboot instead.

 

Save the following as a .bat and run it as administrator:

@echo on
cd /d c:\temp
if not exist %windir%\system32\wbem goto TryInstall
cd /d %windir%\system32\wbem
net stop winmgmt
winmgmt /kill
if exist Rep_bak rd Rep_bak /s /q
rename Repository Rep_bak
for %%i in (*.dll) do RegSvr32 -s %%i
for %%i in (*.exe) do call :FixSrv %%i
for %%i in (*.mof,*.mfl) do Mofcomp %%i
net start winmgmt
goto End

:FixSrv
if /I (%1) == (wbemcntl.exe) goto SkipSrv
if /I (%1) == (wbemtest.exe) goto SkipSrv
if /I (%1) == (mofcomp.exe) goto SkipSrv
%1 /Regserver
:SkipSrv
goto End
:TryInstall
if not exist wmicore.exe goto End
wmicore /s
net start winmgmt
:End

 

I found that in our situation, it does not work if you run it from a network drive. If you do need to deploy it to a widespread group of users, make sure your deployment includes copying the batch file down locally and executing that instead of keeping it in a central location.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...