Jump to content
Welcome to our new Citrix community!
  • 4

Citrix DaaS - Client Connection Failures/Connection Timeout or Logon timeout


Mislav Novacic1709163391

Question

We have Citrix DaaS configured with Azure as hosting environment.
Installed VDA version: 2209.0.0.52

VDA machines: Azure VM Windows 10 multisession version 22H2

Citrix Workspace App are on latest version

 

When users are trying to open some publish app, randomly, for some of them connection progress bar start and then dissapear. In Monitor console we saw Client Connection Failures status either with Connection Timeout or more frequently Logon Timeout

 

Most of the users can connect and work.

 

We have checked Event logs on session host, on Cloud Connector servers and on endpoint problematic machines... Nothing particular we didn't find.

Can anybody give me some points where to look more?

 

Thank you

 

Link to comment

16 answers to this question

Recommended Posts

  • 0

The only place where I see any logging related to these "connection timeouts" is in the AgentLoggerLog on the Cloud Connectors - check yours - just go to C:\ProgramData\Citrix\WorkspaceCloud\Archive and do :

gc * |?{$_.contains("failed")}

I see lots of "An existing connection was forcibly closed by the remote host."

Also lots of messages showing NGS error codes - but I haven't been able to find a listing of what those mean, the ones like these:

- "Application Launch through Rendezvous Failed\",\"code\":\"NGSConn_ERR_00008\"

- "Application Launch Validation Failed\",\"code\":\"NGSConn_ERR_00001\"

 

Would be nice for CItrix to post what those actually mean.

  • Like 1
Link to comment
  • 0

Same issue here:

VDA on Azure: Windows Server 2019 with VDA 2203 LTSR CU2 installed

Any updates on this?

 

Edit:

The only error we see in event viewer is the following: (Error ID 10001 DistributedCOM)

Unable to start a DCOM Server: {hash} as Unavailable/Unavailable. The error:
"0"
Happened while starting this command:
"C:\Windows\System32\sessionmsg.exe" -Embedding

Edited by mgrein69
event viewer error added
Link to comment
  • 0

Hello everybody,

 

we encountered this issue for 1,5 months but we solved it now!
Yesterday, Citrix released 2203 LTSR CU3. We upgraded from CU2 to CU3 and now, the issue is gone!

 

Additional info:

Today, we tried several versions (1912, 2203 without any CU) and both versions worked directly. So Citrix built this issue by itself in 2203 CU2 and solved it in CU3...
So it was a "known" issue, because they fixed it, but I think they don't mention it because they don't want to blame themselves...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...