Jump to content
Welcome to our new Citrix community!

F5 - Keep VDI session alive after SF session timeout


Guillaume Bodin1709155484

Recommended Posts

Hi,

 

Warnin : I am not an F5 expert, at all.

 

When connecting directly to storefront the VDI session stay alive after SF session has timed-out.

However when going through F5 the VDI session is disconnected after SF session has timed-out (also when voluntarily closing the SF session).

I have tried to change the "Logout URI Include" (to a non existing page) in the access profile configuration page. Without any improvement.

 

I there any way to change this behavior and is there any security caveat to do it?

 

Thank you

Link to comment
Share on other sites

Assuming, you're talking the same SF Store? I know there are settings to disconnect the session on logout of SF, but if it's happening to the same store then it's likely not in StoreFront. 

 

Need more info on the F5 set up. Are you using GTM or LTM?  What's load balancing settings look like? Multiple members with persistence or round robin? 

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi Jason,

 

Thank you for your help.

 

Yes we are talking about the same store for direct access and through the F5.

I used this https://wagthereal.com/2015/06/17/storefront-customization-logoff-behavior/ to modify the SF behaviour and changed the LogoffAction value to NONE. It works well when bypassing the F5.

<workspaceControl enabled=”true” autoReconnectAtLogon=”true” logoffAction=”none” showReconnectButton=”false” showDisconnectButton=”false” />

 

We use LTM and APM. 

 

Regarding the SF LoadBalancing : 

Load Balancing Method : Least Connections (member) (default setting of the template wizard).

Priority Group Activation :  Disabled.

 

I'm not quite sure what I need to check to answer your question regarding persistence but : 

Virtual Server List => Citrix_W_PNAgent_webui_https => Load Balancing =>

- default Pool Citrix_W_PNAgent_webui_https_pool

- default Persistence Profile Citrix_W_PNAgent_cookie_persistence

- fallback Citrix_W_PNAgent_source_addresse_persistence

- iRules Citrix_W_PNAgent_loggedout (with the last line saying ACCESS::session remove).

 

Profiles TCP wan : KeepAlive 75 secs 

Profiles TCP lan : keepAlive disabled

 

Basically we used the wizard and therefore have the default settings I suppose.

 

Thank you for your help.

 

G.

 

 

Link to comment
Share on other sites

Hi Jason,

 

Thank you for your help.

 

Yes we are talking about the same store for direct access and through the F5.

I used this https://wagthereal.com/2015/06/17/storefront-customization-logoff-behavior/ to modify the SF behaviour and changed the LogoffAction value to NONE. It works well when bypassing the F5.

<workspaceControl enabled=”true” autoReconnectAtLogon=”true” logoffAction=”none” showReconnectButton=”false” showDisconnectButton=”false” />

 

We use LTM and APM. 

 

Regarding the SF LoadBalancing : 

Load Balancing Method : Least Connections (member) (default setting of the template wizard).

Priority Group Activation :  Disabled.

 

I'm not quite sure what I need to check to answer your question regarding persistence but : 

Virtual Server List => Citrix_W_PNAgent_webui_https => Load Balancing =>

- default Pool Citrix_W_PNAgent_webui_https_pool

- default Persistence Profile Citrix_W_PNAgent_cookie_persistence

- fallback Citrix_W_PNAgent_source_addresse_persistence

- iRules Citrix_W_PNAgent_loggedout (with the last line saying ACCESS::session remove).

 

Profiles TCP wan : KeepAlive 75 secs 

Profiles TCP lan : keepAlive disabled

 

Basically we used the wizard and therefore have the default settings I suppose.

 

Thank you for your help.

 

G.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...