Jump to content
Welcome to our new Citrix community!
  • 0

User profile not loading from FSLogix profile drive since updating to 2208


Jonathan Amadori

Question

I have been having an issue with new images created through App Layering where FSlogix will attach the user's profile drive to their VM but Windows will not load the profile and the user logs into a temp profile.

 

FSLogix is deployed to the end users via the platform layer since our initial VDI deployment and after adding the altitude registry edit have not had problems before now. The App Layering appliance was upgraded from 2202 to 2208 and since then when new images are created and a user logs into a machine group based off this new image, they receive an error message stating there is something wrong with their profile and they have been logged into a temporary profile.

 

What is strange is you can see the profile drive from FSLogix attached to the virtual desktop and in C:\Users you see the local_<username> profile so it appears that FSLogix is at least partially working. I have tried the following to troubleshoot this issue without success:

  • Verified the Altitude registry setting is still set to 138010.
  • Verified the user in question can browse to the FSLogix share and does not have permission issues writing to their profile folder location.
  • Verified this is not an issue with users not having admin permissions on the virtual desktop.
  • Attempted to review the FSLogix profile log and use the FSLogix Profile Status app but have not found anything definitive causing this issue.
  • Added new versions to app and profile layers and a new image based on these, but ran into the same issue.
  • Upgraded the App Layering appliance from 2208 to 2210 but this did not help.
  • Built a new platform layer without FSLogix in it and created a new App Layer with just FSLogix in it.
  • Reinstalled the 2015-2019 C++ redistributable in a version of my OS layer, then built a brand new platform layer from that version, and created a new image from just these 2 layers.  I ran into the same issue.

 

As a workaround I have rolled back to images published before the App Layering update and I do not have a problem with the user logging into a temp profile. What is interesting is that if I build a new image using the exact same layers as an image I rolled back to, the new image has the profile problem while the rolled back image does not. To me this makes me think there is an issue with the App Layering update or the Altitude needs to be change to a different value.

 

Does anyone have any tips or things I can try to resolve this issue?  I am contemplating either restoring my appliance from backup or rolling a new appliance on an older version and exporting/importing all my layers, but would prefer it didn't come to that.

Link to comment

1 answer to this question

Recommended Posts

  • 0

Hi I was waiting for someone else who may have had similar issues to reply.  I have not seen this issue before however the 2208 release did have a few bugs and one may be causing your issues.  Do you know if you are on the original release or the patched release?  Anyway the best thing to do  is to upgrade to 2211 which includes the patches for those issue then see if you still have problem.  That said if you did not update you platform layer when on 2208 I don't think it would be that as an issue b ut still worth upgrading,

 

Here is the info on what was fixed.

https://docs.citrix.com/en-us/citrix-app-layering/4/whats-new.html

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...