Jump to content
Welcome to our new Citrix community!

Certificate Chain Incomplete.


Recommended Posts

Hi All,

I am getting a strange issue. We are running Citrix ADC 5901 on release 13.1 Build 33.52.nc. I ran the ssllabs test against it after we upgraded the firmware and our score dropped to a B. It says we have an incomplete certificate chain. this is strange because I am sure I ran the test against the older firmware and I got an A. The complete chain is there so not sure why it says the chain is now incomplete. Anyone else have this experience?

Link to comment
Share on other sites

  • 3 weeks later...

You should be able to see the complete chain of certificates in the result from SSLLabs.

Then compare it to the certificate objects in NetScaler, and check whether or not any certificate links are missing.

 

Note that the certificate root authority should never be included!

The last certificate to be linked is the intermediate immediately below the root CA.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...