Jump to content
Welcome to our new Citrix community!

How to disable URL safe encoding


Frank Claussner

Recommended Posts

I created a CAG for Authentication in front off a document management system. An AAA virtual server in front of it does not work because we need form based authentication with MFA and redirecting to a dedicated authentication page is not supported.

After teh successful authentication of the user, the user is redirected to a sub url of the dms system where ntlm authentication is implemented. the dms does a 302 redirection to another sub-url with some parameters. and now the strange thing: the adc encodes the url in the "location" header (%2F -> %252F...) which is send to the client browser. The client browser than tries to open that url, which fails, because the url is wrong.

is it possible to disable that behavior?

 

1544750889_Backendanswer-netscalerisgetting.thumb.png.a935c1419eea0adef422f93b043b7d0d.png

Backend answer - client is getting from netscaler.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...