Jump to content
Welcome to our new Citrix community!
  • 0

Cant Delete VDI


Ryan Hull

Question

Hi All

 

I have a number of disks that I am trying to remove from storage.

Some of them I am given the option to delete via XEN, but when trying to do so I get the following error:

 

"The attempt to mark the VID as hidden failed"

 

The others, which are all "Control domian on host" dont give me any option to delete. When trying to remove from the commandline,
either trying to unplug, forget, or destroy, I get simliar issues saying the VDI is in use by another operation:

 

"This operation cannot be performed because this VDI is in use by some other operation
vdi: aced2c3a-b87f-4a59-8551-3d11e7d5ea60 (ZF-WEB15 Disk 000)
operation: destroy"

 

Any idea how I can get rid of these please?

Citrix.PNG

MSACitrix.PNG

Link to comment

4 answers to this question

Recommended Posts

  • 0
On 11/20/2022 at 5:23 PM, Alan Lantz said:

https://support.citrix.com/article/CTX207574/error-virtual-disk-is-owned-by-control-domain-in-xenserver

 

That is a safety feature, but if you know what you are doing you can delete those being held by the control domain.

 

--Alan--

 

 

I have looked at the link you sent, thank you very much.

 

I have followed that like see below:

 

"[root@zf-xenhost03 ~]# list_domains
id |                                 uuid |  state
 0 | bc898efb-447d-45f7-9b45-61cc1e2f1c19 |     R
 1 | 014c3fb6-70df-46b3-176a-48dfa8f08d84 |    B H
 2 | a1184d77-7878-74ef-68af-ee5f1f9db344 |    B H
 3 | 66b90942-dffd-c40e-358e-b0bf8cc544b6 |    B H
16 | d5e6a89c-1c8b-be93-83f9-123ea61c52ec |    B H
17 | 7d161bde-9e99-3603-11d6-19f51673d3b7 |    B H
20 | ba9a3758-145f-d174-3535-a6244068ad24 |    B H
23 | a46c6d34-bad6-d3a4-3941-28aabd4105bd |     RH
[root@zf-xenhost03 ~]# xe vbd-list vm-uuid=bc898efb-447d-45f7-9b45-61cc1e2f1c19
uuid ( RO)             : 131a90f9-9301-7f4f-157d-f9ea7154de80
          vm-uuid ( RO): bc898efb-447d-45f7-9b45-61cc1e2f1c19
    vm-name-label ( RO): Control domain on host: zf-xenhost03
         vdi-uuid ( RO): c8fbe60d-8daf-4480-b79b-d7d8a522834a
            empty ( RO): false
           device ( RO): sm/backend/3cc67f85-270b-92f9-eec2-b56b13e2d9ce/c8fbe60d-8daf-4480-b79b                  -d7d8a522834a


[root@zf-xenhost03 ~]#
[root@zf-xenhost03 ~]#
[root@zf-xenhost03 ~]# xe vbd-unplug uuid=131a90f9-9301-7f4f-157d-f9ea7154de80
Error code: SR_BACKEND_FAILURE_1200
Error parameters: , ,

[root@zf-xenhost03 ~]#"

 

Any ideas what else I check? I also tried tor reboot hosts as suggested in the argument, but got the same error.

 

Cheers.

 

Ryan.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...