Jump to content
Welcome to our new Citrix community!

AAA Client Handler: Found extended error code 589827, ReqType 16386 request /AGServices/Discover


Andreas Koch

Recommended Posts

Hi Guys,

 i'm getting a error "AAA Client Handler: Found extended error code 589827, ReqType 16386 request /AGServices/Discover" on Netscaler 13 latest patch with storefront 2022cu1 in the back.

Every OS is working fine but mobile (android and iOS)

I only found a very old hint within the support. and i tried to turn off ica proxy as mentioned.

 

- NOT WORKING -

 

I'm pretty sure the error is sitting in front of the computer.

If anybody got's a hint, it would be perfect.

 

Thx, Andreas

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

 

same here. 

We have 2 customers with Netscaler last patch in 13.1 or in 13.0 version. Citrix farm with 2203CU1 behind it. With both of them we have the problem that the Workspace App does not work. Over the web it works fine. In the Worspace App we get the following error message when adding the account: "Account with the specified server URL cannot be added. Make sure it is correct or enter your email address."

The Netscaler in the previous release does not have this issue. Of course, after the latest security messages, the customer does not want to go back to the old status. Problem clearly lies with the Netscaler in my opinion. There is already a ticket with Citrix. But the processing is well hardly existent. Also Citrix seems to have problems with good specialists in the job market.




 

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Hi there

 

Unfortunately it isn't working for me. Tried latest 13.0 90.7 build and also tried 13.1 37.38. I have exactly the same error with both versions.

Using 2203 CU2 as a Storefront Server.

 

I was also looking at the proxy settings but there isn't any proxy set so "Direct Access" is in place.

 

Any other suggestions?


Thanks

 

  • Like 1
Link to comment
Share on other sites

40 minutes ago, Michael David1709161559 said:

Hi there

 

Unfortunately it isn't working for me. Tried latest 13.0 90.7 build and also tried 13.1 37.38. I have exactly the same error with both versions.

Using 2203 CU2 as a Storefront Server.

 

I was also looking at the proxy settings but there isn't any proxy set so "Direct Access" is in place.

 

Any other suggestions?


Thanks

 

 

Hi again

 

Just found the problem. An incorrect rewrite policy for multifactor authentication with Microsoft Azure on a NPS server was set on the Netscaler.

After removing the policy the login was working fine. Don't know why this policy was set - seems it isn't needed.

 

Link to comment
Share on other sites

  • 1 month later...

For any future Google-Fu searchers, These comments are spot on:

 

On 11/30/2022 at 5:24 AM, Ralf Theilsiefje1709160267 said:

 

We have 2 customers with Netscaler last patch in 13.1 or in 13.0 version. Citrix farm with 2203CU1 behind it. With both of them we have the problem that the Workspace App does not work. Over the web it works fine. In the Worspace App we get the following error message when adding the account: "Account with the specified server URL cannot be added. Make sure it is correct or enter your email address."

 

On 2/14/2023 at 6:09 AM, Michael David1709161559 said:

Unfortunately it isn't working for me. Tried latest 13.0 90.7 build and also tried 13.1 37.38. I have exactly the same error with both versions.

Using 2203 CU2 as a Storefront Server.

 

Web and mobile access was working fine, but the Workspace App was failing to add the store as indicated above.

We were using 13.1-37.38 in our ADC.

 

On 2/14/2023 at 6:52 AM, Michael David1709161559 said:

 

An incorrect rewrite policy for multifactor authentication with Microsoft Azure on a NPS server was set on the Netscaler.

After removing the policy the login was working fine. Don't know why this policy was set - seems it isn't needed.

 

I just updated to 13.1-42.47 and the issue has disappeared.

 

 

Link to comment
Share on other sites

  • 3 weeks later...

I had this same issue in 13.1-42.47, the ns.log file was reporting  "AAA Client Handler: Found extended error code 589827, ReqType 16386 request /AGServices/Discover", and I would get the "Unable to Add Account on Citrix Workspace App for Windows - Error: "Your Account cannot be added using this server address"" when trying to connect to the Gateway using Citrix Workspace App .

 

It seems to be an issue with the rfWebUI Portal Theme. I had to create a new Portal Theme that used X1 and this resolved the issue.

 

I'm hoping that Citrix will be fixing this issue with the rfWebUI portal theme in the next release so that I can move back to it.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...

Carl - OK - the URL https://support.citrix.com/article/CTX554245/ios-cwa-add-url-failed-error-could-not-verify-server-address

Did fix WINDOWS receiver being able to connect, however it did NOT fix Mac/ARM web clients - They login and it simply loops back to the login page

 

The other themes work fine. X1 and Greenbubbles work properly with ALL clients - so we are JUST talking about the rfWeb theme that does not work.

 

I still have an active case open with Citrix. So I will report if I find anything further.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...