Jump to content
Welcome to our new Citrix community!
  • 0

Nothing Happens when I Double Click "Install Citrix Workspace" on Various MacOS Versions


Nick Snider

Question

I have a 2021 Macbook Pro (Intel chipset) for work.  I previously have had the Workspace app installed and running fine.  Recently however, I ran the uninstaller to try to update my version of Workspace.

 

After I ran the uninstaller, I can't seem to be able to reinstall it.  I've downloaded various various, and tried on two different OS (Big Sur and Ventura), but when I double click the "Install Citrix Workspace" icon after opening the package I downloaded, it does the "opening" woosh animation from MacOS and nothing happens. 

 

I've tried rebooting, running older versions, updating my OS, and installing in safe mode, and it gives the same issue.  I've also tried installing the Intel/non-M1 version as well as the M1 version just for the heck of it, and the same issue occurs.

 

Interestingly, I was provided another Mac temporarily due to a screen issue, and it was able to successfully install on THAT Mac; however, on this one, there is nothing.  That made my theory of "my computer has a bunch of corporate firewall and security type software, so maybe that's blocking it" go away.

Link to comment

1 answer to this question

Recommended Posts

  • 0

Update: I have figured out the issue.  The issue was that, because this was a work computer, it was indeed related to the corporate firewall/management software.  Opening the file was defaulting to open it not using the regular installer app, but using one of my corporate software management applications.  A simple right click > Open With > Installer got everything working.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...