Jump to content
Welcome to our new Citrix community!
  • 0

Machine Catalog creation from an Azure Gallery Image


Garry Down

Question

I'm currently unable to deploy a New Machine Catalog using an image hosted in an Azure Compute Gallery

If I create the Machine Catalog from the Disk connected to my Master Image everything works but if I place a copy of the SAME disk into an Azure Compute Gallery and then try and create a new Machine Catalog I get an error stating the selected image isn't a valid OS or doesn't have the VDA Installed

 

image.png.ac00ab74e18d0c60f36901f2de005836.png

 

And the Error Details are:
image.png.27df3025604142dcf5d88393dd5d9fa8.png

 

The Azure Compute Gallery is set to OS Type: Windows and OS State: Specialized and no changes to the Master Image disk were carried out prior to it being placed into the Azure Compute Gallery

 

I'm unable to find out if these settings are correct or if anything needs to be done to the disk prior to being added to the Azure Compute Gallery

Have I missed something ?

Cheers

Link to comment

3 answers to this question

Recommended Posts

  • 0

Thanks, I have been trying to put the disk into the Azure Compute Gallery programmatically.

 

Running a manual capture worked and highlighted that my code was missing a required setting that was needed to allow the image to be used to deploy a machine catalog but was not needed to create the Azure Compute Gallery image in the first place

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...