Jump to content
Welcome to our new Citrix community!
  • 0

Citrix workspace storefront / pass-through authentication config via intune


Maximiliano Morsia

Question

Hello all,

So, Finally I've been able to ingest the citrix admx files thanks to this slightly modified (combo-boxes removed) version by Adam Gross

Toolbox/Intune/ADMXIngestion at master · AdamGrossTX/Toolbox · GitHub

settings are now deployed correctly to my test group, I can see the storefront url and pass-through authentication settings in the registry editor under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\Receiver\Sites

and

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Logon\Local Credentials

yet the workspace client isn't taking them into account, and it asks for the storefront URL and, after inserting it, authentication.

This config is at the moment aimed only at full azure devices. Hybrid devices targeted by GPOs with same configuration are working as expected.

Am I missing something? How can I "activate" those settings for the workspace app in order to be considered?

Edited by Maximiliano Morsia
missing information
Link to comment

1 answer to this question

Recommended Posts

  • 0

Ok solved this: first of all I forgot to enable single sign-on for netscaler gateway, but most importantly, I needed to deploy the following sites to "intranet" in "internet options".

https://aadg.windows.net.nsatc.net; https://autologon.microsoftazuread-sso.com; store URL domain

Also I had to make sure automatic login is selected in the zone settings

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...