Jump to content
Welcome to our new Citrix community!

Storefront 2203 LTSR CU1, cannot add a new Deployment


Roberto Pereira

Recommended Posts

Hello,

 

We have a problem with a complete new Citrix XenDesktop Installation. As we had some Problems with Storefront during the Update, we have made a completely new installation. This installation works on a physical server (DELL Server) with Windows Server 2019 (Build 1809). No vmware Tools are installed as it is physical.

 

We installed following Versions:

DDC 2209

Director 2209

License SRV 11.17.2.0

Storefront SRV 2203 LTSR CU1

 

We could install all components without errors. But when we try to configure a new deployment in Storefront, the new Store cannot be added. The installation stopes with following error:

*****

Neue Serverbereitstellung Beim Ausführen des folgenden Befehls ist ein Fehler aufgetreten: 'Set-DSNewClusterEnvironment' An error occurred while adding the StoreFront configuration API. Eine Ausnahme vom Typ "Citrix.DeliveryServices.Framework.Web.Deployment.Exceptions.WebApplicationAlreadyExists" wurde ausgelöst. In C:\Program Files\Citrix\Receiver StoreFront\Management\Cmdlets\ClusterConfigurationModule.psm1:1257 Zeichen:9

+ Add-STFConfigurationApi

+ ~~~~~~~~~~~~~~~~~~~~~~~

An error occurred while adding the StoreFront configuration API. Eine Ausnahme vom Typ "Citrix.DeliveryServices.Framework.Web.Deployment.Exceptions.WebApplicationAlreadyExists" wurde ausgelöst.

 

Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces.Exceptions.PowerShellExecutionException: Beim Ausführen des folgenden Befehls ist ein Fehler aufgetreten: 'Set-DSNewClusterEnvironment' An error occurred while adding the StoreFront configuration API. Eine Ausnahme vom Typ "Citrix.DeliveryServices.Framework.Web.Deployment.Exceptions.WebApplicationAlreadyExists" wurde ausgelöst. In C:\Program Files\Citrix\Receiver StoreFront\Management\Cmdlets\ClusterConfigurationModule.psm1:1257 Zeichen:9

+ Add-STFConfigurationApi

+ ~~~~~~~~~~~~~~~~~~~~~~~ ---> System.Management.Automation.ActionPreferenceStopException: Der ausgeführte Befehl wurde beendet, da die Einstellungsvariable "ErrorActionPreference" oder ein allgemeiner Parameter auf "Stop" festgelegt ist: An error occurred while adding the StoreFront configuration API. Eine Ausnahme vom Typ "Citrix.DeliveryServices.Framework.Web.Deployment.Exceptions.WebApplicationAlreadyExists" wurde ausgelöst.. bei System.Management.Automation.Runspaces.PipelineBase.Invoke(IEnumerable input) bei Citrix.DeliveryServices.PowerShell.Command.Runner.PowerShellCommandRunner.InvokeCommand(IPowerShellCommand command, Command powerShellCommand) bei Citrix.DeliveryServices.PowerShell.Command.Runner.PowerShellCommandRunner.RunCommand(IPowerShellCommand command) --- Ende der internen Ausnahmestapelüberwachung --- bei Citrix.DeliveryServices.PowerShell.Command.Runner.PowerShellCommandRunner.RunCommand(IPowerShellCommand command) bei Citrix.DeliveryServices.Admin.FirstTimeConfiguration.Common.DeploymentSteps.DeploymentBase.Deploy() bei Citrix.DeliveryServices.Admin.FirstTimeConfiguration.ScopeNode.Wizard.Models.FTUWizardCreatingViewModel.CreateDeployment()

*****

 

After that we uninstalled Storefront 2203. After a Reboot we installed Storefront LTSR 1912 CU5 but we have still the same error. Now we have again SF 2203 LTSR CU1.

 

There is a similar article here, but the solutions was to check VMware Tools Version. But we are using a physical Server: https://discussions.citrix.com/topic/403845-1906-clean-install-error/

 

We tried also to Reset SF to Factory Defaults without success. But this also does not make sense for us, as we had the problem from beginning after a fresh new installation.

 

Are there more with this error? I have also an open ticket with Citrix. I will update as soon there are news.

 

Thank you and Regards,

Roberto

Link to comment
Share on other sites

  • 2 weeks later...

Finally I found the error. Unfortunately the Citrix Support could not help. Perhaps there is an error in the installer when checking the prerequisits. 

a) Install the Features .NET 3.5 and Powershell 2.0

b) Uninstall Storefront (delete folders like C:\Program Files\Citrix\Storefront Receiver, C:\inetpub\wwwroot\Citrix and C:\inetpub\wwwroot\AGService)

c) Reboot Server

d) Install Storefront

 

After that, I could add a new Deployment without errors.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...