Jump to content
Welcome to our new Citrix community!

Update to 13.1 33.47nc now get error: "Cannot retrieve discovery document" with WorkspaceApp from extern


lagermax

Recommended Posts

Hi guys,

 

till the last release from Netscaler everything works fine, on friday i startet the upgrade to 33.47nc and after that, no one can sign-in from external.

The users gets two authentication prompts and after that, the error occurs "Cannot retrieve discovery document" or "Can't add store".

 

I changed nothing on the configuration side. 

 

maybe some hints from one pro?

Link to comment
Share on other sites

Hi Carl,

 

thanks for your answer. I upgraded from version 27.59, HSTS is disabled. Tried also the time-out in the session profile for the workspaceapp without success :(. It happens only with the workspaceApp, Receiver for Web is working fine. 

Link to comment
Share on other sites

Not sure why but I changed the timeout under global settings then overrode it in both session profiles to the same setting I had in global. Seems to be working normally now.

 

Try setting Session Time-out in global and in the session profiles as well. Also make sure its the session time out and not client idle time out.

  • Like 1
Link to comment
Share on other sites

YES! Worked for me too, in my case it was enough to set the session timeout in the session profile. I also found the following note in the citrix docs:

 

https://docs.citrix.com/en-us/citrix-gateway/current-release/vpn-user-config/configure-plugin-connections/configure-time-out-settings.html#:~:text=using the GUI-,On the Configuration tab%2C in the navigation pane%2C expand Citrix,type the number of minutes.

 

so, thank you very much Kyle and Carl and have a nice day!

 

 

Link to comment
Share on other sites

  • 1 month later...

I'm having the same problem after updating from 13.1-27.59 to 13.1-33.52.

Just adding 720 to the global settings hasn't helped.

I'm not sure how to configure the session policy expression, can someone give me an example?

Thank you!

 

Edit: So after some trial and error with creating a session policy/profile and deleting those new session policy/profiles it is working again with only using the global settings.

Session Time-out: 720

Thanks for the thread! 

Edited by Thomas MCcDonaugh
Answer given worked
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...