Jump to content
Welcome to our new Citrix community!
  • 0

Avoid having to log off to enable SSON


Gwyn Williams1709162899

Question

I use SCCM to silently install/upgrade Citrix Workspace app on all of our endpoint machines. We use /includeSSON and ENABLE_SSON=Yes in the install command to enable SSON so that it passes the logged on Windows credentials into the Citrix sessions. SSON all works fine, but after the install, when the user tries to launch any application, they're presented with the logon authentication box, and they have to logoff/logon in order for the SSON to work seamlessly from then on.

 

Given that I don't want them to put any user credentials into the Workspace app (in case they use the wrong ones), is there any way to avoid having to log off in order to sort out the SSON? Is there any command that I can run as part of the installation script (service restart, or anything else) to do this?

Link to comment

7 answers to this question

Recommended Posts

  • 0

Hi Sjoerd, sorry I've been away.

 

No actually, I haven't done this part with the GPOs.  I'm assuming this is on the endpoint machine, right?

 

In my company, adding any custom ADM/ADMX has a long change control process, even for testing, so what I've done instead is found out what are the actual registry settings that this Group Policy sets: https://admx.help/?Category=CitrixWorkspace&Policy=receiver.Policies.receiver::Policy_LocalCredentialsLockdown

 

On a test machine I've then, uninstalled Workspace app and rebooted, then set the above registry settings, and then reinstalled Workspace app with silent command. Unfortunately, I'm still getting the login authentication prompt.

 

 

Link to comment
  • 0

Hi Sjoerd,

 

Thanks, I had a look at the article (and another one referenced within). My StoreFront is configured OK, but I did make some changes to the client-side Internet Options based on the articles. I added the StoreFront Base URL into Trusted Sites on my test machine, as well as setting the User Auth part to 'Automatic logon with current user name and password'. So I did another test of uninstalling, rebooting, and then re-installing the Workspace app. But unfortunately I'm still having the same issue.

 

The Network Provider Order doesn't have Citrix Single Sign-on at the top of the list, but this can't be the issue because even after the logoff/logon (i.e. when it starts to work) the Citrix item is still not at the top.

 

Just to reiterate, it's only straight after install that it doesn't work - it always works after I've done a logoff/logon.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...