Jump to content
Welcome to our new Citrix community!
  • 0

Warning: should_multipath() only based on wwids. dev = sda


Eduard Meiler

Question

Hi,

 

i have a problem after reboot my (Dell 440 ) with my  Xen Hypervisor 8.2 CU1 the iSCSI Storage ist not attached.

The Systme is already running for 2 Years without a problem. 

 

both Host shows multipath is not active. Biut they are active on the system.

 

Repair did not helped.

 

I checked those commands

 

[root@xen241 ~]# multipath -ll
[root@xen241 ~]# rescan-scsi-bus.sh
Scanning SCSI subsystem for new devices
Scanning host 0 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 0 2 0 0 ...
OLD: Host: scsi0 Channel: 02 Id: 00 Lun: 00
      Vendor: DELL     Model: PERC H330 Adp    Rev: 4.30
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning host 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 2 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 3 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 4 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 5 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 6 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 7 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 8 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 9 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 10 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 11 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 12 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 13 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 14 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 15 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 16 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
0 new or changed device(s) found.
0 remapped or resized device(s) found.
0 device(s) removed.
 

[root@xen241 ~]# multipath -v4
Sep 16 01:19:36 | loading /lib64/multipath/libcheckdirectio.so checker
Sep 16 01:19:36 | loading /lib64/multipath/libprioconst.so prioritizer
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda
Sep 16 01:19:36 | sda: not found in pathvec
Sep 16 01:19:36 | sda: mask = 0x3f
Sep 16 01:19:36 | sda: dev_t = 8:0
Sep 16 01:19:36 | open '/sys/devices/pci0000:16/0000:16:02.0/0000:17:00.0/host0/                                                            target0:2:0/0:2:0:0/block/sda/size'
Sep 16 01:19:36 | sda: size = 936640512
Sep 16 01:19:36 | sda: vendor = DELL
Sep 16 01:19:36 | sda: product = PERC H330 Adp
Sep 16 01:19:36 | sda: rev = 4.30
Sep 16 01:19:36 | sda: h:b:t:l = 0:2:0:0
Sep 16 01:19:36 | open '/sys/devices/pci0000:16/0000:16:02.0/0000:17:00.0/host0/                                                            target0:2:0/0:2:0:0/state'
Sep 16 01:19:36 | sda: path state = running

Sep 16 01:19:36 | sda: 58303 cyl, 255 heads, 63 sectors/track, start at 0
Sep 16 01:19:36 | sda: serial = 00cf1d310c116c162600d41edb002740
Sep 16 01:19:36 | sda: get_state
Sep 16 01:19:36 | sda: detect_checker = 1 (config file default)
Sep 16 01:19:36 | sda: path checker = directio (internal default)
Sep 16 01:19:36 | sda: checker timeout = 90000 ms (sysfs setting)
Sep 16 01:19:36 | directio: called for 800
Sep 16 01:19:36 | directio: called in synchronous mode
Sep 16 01:19:36 | directio: starting new request
Sep 16 01:19:36 | directio: io finished 4096/0
Sep 16 01:19:36 | sda: directio state = up
Sep 16 01:19:36 | sda: uid_attribute = ID_SERIAL (internal default)
Sep 16 01:19:36 | sda: got wwid of '36f402700db1ed40026166c110c311dcf'
Sep 16 01:19:36 | sda: uid = 36f402700db1ed40026166c110c311dcf (udev)
Sep 16 01:19:36 | sda: detect_prio = 1 (config file default)
Sep 16 01:19:36 | sda: prio = const (internal default)
Sep 16 01:19:36 | sda: prio args =  (internal default)
Sep 16 01:19:36 | sda: const prio = 1
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda/sda1
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda/sda2
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda/sda3
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda/sda4
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda/sda5
Sep 16 01:19:36 | Discover device /sys/devices/pci0000:16/0000:16:02.0/0000:17:0                                                            0.0/host0/target0:2:0/0:2:0:0/block/sda/sda6
Sep 16 01:19:36 | Discover device /sys/devices/virtual/block/dm-0
Sep 16 01:19:36 | dm-0: not found in pathvec
Sep 16 01:19:36 | dm-0: device node name blacklisted
Sep 16 01:19:36 | Discovered 1/2 paths
===== paths list =====
uuid                              hcil    dev dev_t pri dm_st chk_st vend/prod
36f402700db1ed40026166c110c311dcf 0:2:0:0 sda 8:0   1   undef undef  DELL    ,
Sep 16 01:19:36 | Warning: should_multipath() only based on wwids. dev = sda
Sep 16 01:19:36 | wwid 36f402700db1ed40026166c110c311dcf not in wwids file, skip                                                            ping sda
Sep 16 01:19:36 | const prioritizer refcount 1
Sep 16 01:19:36 | directio checker refcount 1
Sep 16 01:19:36 | unloading const prioritizer
Sep 16 01:19:36 | unloading directio checker
 

Need help please.

 

Regards

Eduard

 

 

 

 

 

db.png

Link to comment

5 answers to this question

Recommended Posts

  • 0

just an update. I have another system which is 1:1 like the broken one. If I execute the commands there, i git this results:

 

[root@xen14 ~]# multipath -ll
360003ff44dc75adc865169d8492e276e dm-1 MSFT    ,Virtual HD
size=10T features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 15:0:0:0 sdb 8:16 active ready running
  `- 16:0:0:0 sdc 8:32 active ready running
[root@xen14 ~]# rescan-scsi-bus.sh
Scanning SCSI subsystem for new devices
Scanning host 0 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 0 0 0 0 ...
OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: ST1000NM0018-2F2 Rev: EA04
      Type:   Direct-Access                    ANSI SCSI revision: 06
Scanning host 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 2 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 3 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 4 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 5 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 6 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 7 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 8 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 9 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 10 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 10 0 0 0 ...
OLD: Host: scsi10 Channel: 00 Id: 00 Lun: 00
      Vendor: PLDS     Model: DVD+-RW DS-8ABSH Rev: LD51
      Type:   CD-ROM                           ANSI SCSI revision: 05
Scanning host 11 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 12 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 13 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 14 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 15 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 15 0 0 0 ...
OLD: Host: scsi15 Channel: 00 Id: 00 Lun: 00
      Vendor: MSFT     Model: Virtual HD       Rev: 10.0
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning host 16 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 16 0 0 0 ...
OLD: Host: scsi16 Channel: 00 Id: 00 Lun: 00
      Vendor: MSFT     Model: Virtual HD       Rev: 10.0
      Type:   Direct-Access                    ANSI SCSI revision: 05
0 new or changed device(s) found.
0 remapped or resized device(s) found.
0 device(s) removed.
[root@xen14 ~]#
 

 

Link to comment
  • 0

just an update. I have another system which is 1:1 like the broken one. If I execute the commands there, i git this results:

 

[root@xen14 ~]# multipath -ll
360003ff44dc75adc865169d8492e276e dm-1 MSFT    ,Virtual HD
size=10T features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 15:0:0:0 sdb 8:16 active ready running
  `- 16:0:0:0 sdc 8:32 active ready running
[root@xen14 ~]# rescan-scsi-bus.sh
Scanning SCSI subsystem for new devices
Scanning host 0 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 0 0 0 0 ...
OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: ST1000NM0018-2F2 Rev: EA04
      Type:   Direct-Access                    ANSI SCSI revision: 06
Scanning host 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 2 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 3 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 4 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 5 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 6 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 7 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 8 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 9 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 10 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 10 0 0 0 ...
OLD: Host: scsi10 Channel: 00 Id: 00 Lun: 00
      Vendor: PLDS     Model: DVD+-RW DS-8ABSH Rev: LD51
      Type:   CD-ROM                           ANSI SCSI revision: 05
Scanning host 11 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 12 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 13 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 14 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 15 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 15 0 0 0 ...
OLD: Host: scsi15 Channel: 00 Id: 00 Lun: 00
      Vendor: MSFT     Model: Virtual HD       Rev: 10.0
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning host 16 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
 Scanning for device 16 0 0 0 ...
OLD: Host: scsi16 Channel: 00 Id: 00 Lun: 00
      Vendor: MSFT     Model: Virtual HD       Rev: 10.0
      Type:   Direct-Access                    ANSI SCSI revision: 05
0 new or changed device(s) found.
0 remapped or resized device(s) found.
0 device(s) removed.
[root@xen14 ~]#
 

 

Link to comment
  • 0

Interesting. I have similar issue, but with brand new 8.2 deployment. 

3 Dell servers with 25Gb cards and ME5012

It works as long as you don't need multipath. 

I have multipath configured according to Dell Deployment Guide.

In my case I get following error when trying to create SR
 

Device Mapper path missing [opterr=Device mapper path /dev/mapper/3600c0ff00066a94d4cf1606301000000 not found]

Did this happened after you upgraded to 8.2? If so, can you rollback to last known version?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...