Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Cloud DaaS - Azure AD Hybrid Joined Published Desktops


Zeshan Butt

Question

Hello,

 

We are using Citrix Cloud with published Desktops. Environment consists of a Cloud Connector, Domain Controller, File Server, and a shared Windows 10 Multi-Session host (all hosted in Azure).

MCS is used to provision the Host. We have added the Host as a Hybrid Azure AD joined following the Citrix article:

 

https://docs.citrix.com/en-us/citrix-daas/manage-deployment/machine-identities/hybrid-azure-ad-joined.html

 

In the Office tenant Security defaults are enabled which enabled 2FA for all accounts. We are experiencing the following issue, each time the Host is rebooted once a user opens any office application they are asked to re-authenticate their 2FA.

 

If the host remains online (not rebooted), each time users login they are not prompted for their 2FA. We have established it is not a profile related item as users can log off and log back into the host without any prompts but soon as the host is rebooted all users are asked to re-authenticate their 2FA.

 

Look for some help on how to address this so we can keep the rolling 14 days for 2FA prompts as per Microsoft documentation.

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...