Jump to content
Welcome to our new Citrix community!

ADC - loadbalancing Exchange - SSL handshake failed after hardening exchange


Recommended Posts

Hi,

 

loadbalancing Exchange was working fine until we hardened Exchange following this article:

https://docs.microsoft.com/en-us/exchange/exchange-tls-configuration?view=exchserver-2019

Current situation:

- Exchange only accepts TLS1.2 with the recommended TLS 1.2 cipher suites

- on ADC (version 13.0.71) I'm using a SSL backend profile (only TLS1.2 enabled, 4 SSL ciphers - which are in the above list configured on Exchange, 'Deny SSL Renegotiation' set to 'NONSECURE')

 

I have tried by setting 'AllowInsecureRenegoClients' and 'AllowInsecureRenegoServers' on Exchange on '0' (following hardening guide) and on '1' (following different articles on internet) but it still doesn't work.

 

I have tried several things and articles (also several posts in this forum) but I don't get it working.

 

An idea would be to re-enable TLS 1.1 again, but this is something I would like to avoid.

 

Someone can help me with this?

 

Thanks!

 

Gijs.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...