Jump to content
Welcome to our new Citrix community!
  • 2

Window focus changes randomly since 2206


Sandy Williams

Question

I upgraded my Windows workspace app from 2203 to 2207 a few weeks ago and since then my windows will randomly change focus.  I'll be working way when the window behind the one I'm working on will come into focus.  It happens with any app.  The workaround is to ensure all my windows are minimized and the one I am working on is the only one that is not.  I have a colleague who is complaining of the same since upgrading to 2206.  It's completely random/not predictable.  I have opened a ticket with support but they seem to think I'm the only one.  I have already reinstalled the app.

Link to comment

25 answers to this question

Recommended Posts

  • 0

I just downgraded to 2205 this afternoon and in the few hours of using Citrix the focus change did not happen.  I spoke with support today and apparently engineering IS aware of this issue and they are possibly going to send me a private fix.  Still early.  I have since asked other people in my organization who have upgraded to 2206 and they too are experiencing this issue.

Link to comment
  • 0
On 8/29/2022 at 3:43 PM, Sandy Williams said:

The private fix seems to be working. It was a replacement of a DLL file.  They told me this would be fixed in their next release.

 

Hello, can you share your case number so that we can easier get the same dll file as you.

Link to comment
  • 0

I'm glad to have found this thread. I'm having the same thing. Didn't get the problem with 2108, but the moment I upgraded to 2207 I started to get complaints from users. I've tried upgrading to 2209 but that doesn't fix it so I assume that 2209 doesn't contain the fix mentioned above.

 

I'm not holding my breath for this fix to be included in 2210, since I assume they're always working on a few different versions at the same time.

 

Sandy can you share your case number so that I can ask Citrix for the same dll? Thanks.

Link to comment
  • 0
16 hours ago, Sandy Williams said:

My case was archived cause I was told it was going to be fixed in 2209.  Its not as bad as it was in 2207 but it is still happening.

 

Ticket 81325976

We have this same issue at our company in the last 2 versions of Workspace (22.9.0.28 and 22.7.0.24). Strange how it's not mentioned in any known-issues documents. I'll keep searching for a fix but not having a support contract it's gonna take a while.   We're looking at moving to the LTSR version 22.03.1000 which doesn't appear to have this issue.

Don't suppose you have the dll they replaced to hand? Would like to try manually replacing it on my system to see if that fixes it

Edited by David Turner
added version numbers for clarification
Link to comment
  • 0
1 hour ago, Christoph Kolbicz1709156882 said:

Workspace App  2212 was released and mentions this fix: When you open a published app in seamless mode, other local or seamless apps might appear in the foreground and cover the published app. [CVADHELP-20742]

Thanks for the info. My preliminary tests show 2212 has resolved my windows focus issues .  ? 

 

Link to comment
  • 0

Has anyone else continued to have this issue?  I have a couple of machines running 23.3.9.38 (2302) and they are demonstrating the exact issues as described in CTX463924.  If they minimize the Chrome/Edge browsers, as of right now it seems to resolve the issue.  If the restore those windows and leave them up behind the Citrix Workspace App, that's when the issue seems to occur.  

Link to comment
  • 0

Hey all. Does anyone have focus issue with 2212/2302 ?

 

We were updating all our CWA 1907/1912 to 2209 for the Background blurring or effects for Microsoft Teams optimization feature. We had a lot of problem with focus so we changed for 2212, where the problem is supposed to be solved (CVADHELP-20742). The problem seems to be solved for most people but some are still experiencing the problem.

 

Did the private fix solve the problem with 2212/2302 if you tried it with those versions?

 

Edit :

Replacing the vdtwin.dll file in the C:\Program Files (x86)\Citrix\ICA Client\ folder seems to fix the problem with the CWA 2212 version. The vdtwin.dll file was taken from a CWA 2205. If it can help some of you.

 

Thx

Edited by Etienne Tanguay
Add informations
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...